summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-12-02 19:52:12 +0000
committerJustin Lecher <jlec@gentoo.org>2017-12-02 20:09:07 +0000
commite410ec23363ed48c5a99f1b1794bfe66dbb9c8cc (patch)
tree07d11092b0c47cacef87e5f79eda15f90f434ffb /dev-python/pythonz-bd/pythonz-bd-1.11.4.ebuild
parentdev-python/resumable-urlretrieve: New package (diff)
downloadgentoo-e410ec23363ed48c5a99f1b1794bfe66dbb9c8cc.tar.gz
gentoo-e410ec23363ed48c5a99f1b1794bfe66dbb9c8cc.tar.bz2
gentoo-e410ec23363ed48c5a99f1b1794bfe66dbb9c8cc.zip
dev-python/pythonz-bd: New package
Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-python/pythonz-bd/pythonz-bd-1.11.4.ebuild')
-rw-r--r--dev-python/pythonz-bd/pythonz-bd-1.11.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pythonz-bd/pythonz-bd-1.11.4.ebuild b/dev-python/pythonz-bd/pythonz-bd-1.11.4.ebuild
new file mode 100644
index 000000000000..371d0631468e
--- /dev/null
+++ b/dev-python/pythonz-bd/pythonz-bd-1.11.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage python installations in your system, berdario's shallow fork"
+HOMEPAGE="
+ https://github.com/berdario/pythonz/tree/bd
+ https://pypi.python.org/pypi/pythonz-bd"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/resumable-urlretrieve[${PYTHON_USEDEP}]' 'python3*')"