summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2018-12-12 16:30:09 -0800
committerPatrick McLean <chutzpah@gentoo.org>2018-12-12 16:30:38 -0800
commita8889cff995e988ca22f336f1c793ca8e95cb96a (patch)
treeda9034580baa535e020813891bc0c48839e86ff9 /dev-python/pytoml/pytoml-0.1.20.ebuild
parentnet-analyzer/fail2ban: Stable (diff)
downloadgentoo-a8889cff995e988ca22f336f1c793ca8e95cb96a.tar.gz
gentoo-a8889cff995e988ca22f336f1c793ca8e95cb96a.tar.bz2
gentoo-a8889cff995e988ca22f336f1c793ca8e95cb96a.zip
dev-python/pytoml: Version bump to 0.1.20
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pytoml/pytoml-0.1.20.ebuild')
-rw-r--r--dev-python/pytoml/pytoml-0.1.20.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytoml/pytoml-0.1.20.ebuild b/dev-python/pytoml/pytoml-0.1.20.ebuild
new file mode 100644
index 000000000000..7c1a378738d4
--- /dev/null
+++ b/dev-python/pytoml/pytoml-0.1.20.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1
+
+TOML_TEST_COMMIT="b212790a6b7367489f389411bda009e5ff765f20"
+
+DESCRIPTION="A TOML-0.4.0 parser/writer for Python"
+HOMEPAGE="https://github.com/avakar/pytoml"
+SRC_URI="https://github.com/avakar/pytoml/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://github.com/avakar/toml-test/archive/${TOML_TEST_COMMIT}.tar.gz -> toml-test-${TOML_TEST_COMMIT}.tar.gz )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ cp -R ../toml-test-${TOML_TEST_COMMIT}/* test/toml-test/ || die
+ ${EPYTHON} test/test.py || die
+}