summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-03-28 18:34:52 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-03-28 18:43:07 -0700
commit4ff12d1d193f58779b4b331d7699f07e240fab0c (patch)
tree259f6f2399f568777dabc863fcc90de83fdf198f /dev-python/pytrie/pytrie-0.3.ebuild
parentdev-python/pynacl: Version bump (diff)
downloadgentoo-4ff12d1d193f58779b4b331d7699f07e240fab0c.tar.gz
gentoo-4ff12d1d193f58779b4b331d7699f07e240fab0c.tar.bz2
gentoo-4ff12d1d193f58779b4b331d7699f07e240fab0c.zip
dev-python/pytrie: Version bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2_p30
Diffstat (limited to 'dev-python/pytrie/pytrie-0.3.ebuild')
-rw-r--r--dev-python/pytrie/pytrie-0.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pytrie/pytrie-0.3.ebuild b/dev-python/pytrie/pytrie-0.3.ebuild
new file mode 100644
index 000000000000..e52e46268470
--- /dev/null
+++ b/dev-python/pytrie/pytrie-0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="PyTrie"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A pure Python implementation of the trie data structure."
+HOMEPAGE="https://github.com/gsakkis/pytrie/ https://pypi.python.org/pypi/PyTrie"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/sortedcontainers[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}