summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyvorbis
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyvorbis')
-rw-r--r--dev-python/pyvorbis/Manifest1
-rw-r--r--dev-python/pyvorbis/files/pyvorbis-1.4-python25.patch65
-rw-r--r--dev-python/pyvorbis/files/pyvorbisfile.c-1.4.patch20
-rw-r--r--dev-python/pyvorbis/metadata.xml5
-rw-r--r--dev-python/pyvorbis/pyvorbis-1.4-r4.ebuild39
5 files changed, 130 insertions, 0 deletions
diff --git a/dev-python/pyvorbis/Manifest b/dev-python/pyvorbis/Manifest
new file mode 100644
index 000000000000..3e97c4ee3966
--- /dev/null
+++ b/dev-python/pyvorbis/Manifest
@@ -0,0 +1 @@
+DIST pyvorbis-1.4.tar.gz 39045 SHA256 a7154541cea58304feff30752243eab862131c7589d72c200c8ad722d3bf1647 SHA512 c0b5ebb5d22f97b20f56a0b49e43675764fe057afa2d5de22eab9b8b73fb542186e7488cb0ba31b7af433cef1a88e815eb3e88a4609a2657ae5fba1017bdb89c WHIRLPOOL ae1b9025443a987c3dc51e4942ea2f709bee20f93156b8187d2db7a633df342ae9f26605a37da48c22db4bb7bb90fbcc96390ae56d5d2afa5e25d3902d0b0849
diff --git a/dev-python/pyvorbis/files/pyvorbis-1.4-python25.patch b/dev-python/pyvorbis/files/pyvorbis-1.4-python25.patch
new file mode 100644
index 000000000000..18028dc7a8e7
--- /dev/null
+++ b/dev-python/pyvorbis/files/pyvorbis-1.4-python25.patch
@@ -0,0 +1,65 @@
+diff -ur pyvorbis-1.4-old/src/pyvorbiscodec.c pyvorbis-1.4/src/pyvorbiscodec.c
+--- pyvorbis-1.4-old/src/pyvorbiscodec.c 2003-05-13 11:17:13.000000000 +0300
++++ pyvorbis-1.4/src/pyvorbiscodec.c 2007-09-20 01:57:54.000000000 +0300
+@@ -118,7 +118,7 @@
+ {
+ vorbis_dsp_clear(PY_DSP(self));
+ Py_XDECREF(((py_dsp *)self)->parent);
+- PyMem_DEL(self);
++ PyObject_Del(self);
+ }
+
+ static PyObject*
+@@ -447,7 +447,7 @@
+ {
+ vorbis_block_clear(PY_BLOCK(self));
+ Py_XDECREF(((py_block *)self)->parent);
+- PyMem_DEL(self);
++ PyObject_Del(self);
+ }
+
+ static PyObject*
+diff -ur pyvorbis-1.4-old/src/pyvorbisfile.c pyvorbis-1.4/src/pyvorbisfile.c
+--- pyvorbis-1.4-old/src/pyvorbisfile.c 2003-12-19 09:11:02.000000000 +0200
++++ pyvorbis-1.4/src/pyvorbisfile.c 2007-09-20 01:59:41.000000000 +0300
+@@ -173,8 +173,7 @@
+ if (ret == NULL) {
+ PyMem_DEL(newobj);
+ return NULL;
+- } else
+- Py_DECREF(ret);
++ }
+
+ return (PyObject *) newobj;
+ }
+@@ -195,7 +194,8 @@
+ fclose(py_self->c_file);
+ }
+
+- PyMem_DEL(self);
++ free(py_self->ovf);
++ PyObject_Del(self);
+ }
+
+ static PyObject *
+diff -ur pyvorbis-1.4-old/src/pyvorbisinfo.c pyvorbis-1.4/src/pyvorbisinfo.c
+--- pyvorbis-1.4-old/src/pyvorbisinfo.c 2003-12-19 09:51:36.000000000 +0200
++++ pyvorbis-1.4/src/pyvorbisinfo.c 2007-09-20 02:01:58.000000000 +0300
+@@ -134,7 +134,7 @@
+ static void
+ py_ov_info_dealloc(PyObject *self)
+ {
+- PyMem_DEL(self);
++ PyObject_Del(self);
+ }
+
+ #define CMP_RET(x) \
+@@ -418,7 +418,7 @@
+ free(ovc_self->vc);
+ }
+
+- PyMem_DEL(self);
++ PyObject_Del(self);
+ }
+
+
diff --git a/dev-python/pyvorbis/files/pyvorbisfile.c-1.4.patch b/dev-python/pyvorbis/files/pyvorbisfile.c-1.4.patch
new file mode 100644
index 000000000000..5d1d8ffc7c77
--- /dev/null
+++ b/dev-python/pyvorbis/files/pyvorbisfile.c-1.4.patch
@@ -0,0 +1,20 @@
+--- src/pyvorbisfile.c.orig 2003-12-19 07:11:02.000000000 +0000
++++ src/pyvorbisfile.c 2005-09-03 20:02:19.000000000 +0100
+@@ -190,9 +190,6 @@
+ /* If file was opened from a file object, decref it, so it can
+ close */
+ Py_DECREF(py_self->py_file);
+- } else {
+- /* Otherwise, we opened the file and should close it. */
+- fclose(py_self->c_file);
+ }
+
+ PyMem_DEL(self);
+@@ -260,7 +257,6 @@
+
+ retval = ov_open(file, self->ovf, initial, ibytes);
+
+- self->c_file = file;
+ if (retval < 0) {
+ if (fname != NULL)
+ fclose(file);
diff --git a/dev-python/pyvorbis/metadata.xml b/dev-python/pyvorbis/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/pyvorbis/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/pyvorbis/pyvorbis-1.4-r4.ebuild b/dev-python/pyvorbis/pyvorbis-1.4-r4.ebuild
new file mode 100644
index 000000000000..5062ba740e4a
--- /dev/null
+++ b/dev-python/pyvorbis/pyvorbis-1.4-r4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Python bindings for the ogg.vorbis library"
+HOMEPAGE="http://ekyo.nerim.net/software/pyogg/"
+SRC_URI="http://ekyo.nerim.net/software/pyogg/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-python/pyogg-1.1[${PYTHON_USEDEP}]
+ >=media-libs/libogg-1.0
+ >=media-libs/libvorbis-1.0"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS COPYING ChangeLog NEWS README )
+PATCHES=(
+ "${FILESDIR}/pyvorbisfile.c-1.4.patch"
+ "${FILESDIR}/${P}-python25.patch"
+)
+
+python_configure_all() {
+ tc-export CC
+ "${PYTHON}" config_unix.py --prefix /usr || die "Configuration failed"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ insinto /usr/share/doc/${PF}/examples
+ doins test/*
+}