summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-14 14:51:34 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-14 15:12:29 +0300
commit406a66aefc336cf90844a7a995fb35900277b70e (patch)
tree5309d1332bde8e9a9a798dfed82a4a71209ae0fa /dev-python/pywavelets
parentdev-python/numpydoc: enable py3.10, cleaner test deselect (diff)
downloadgentoo-406a66aefc336cf90844a7a995fb35900277b70e.tar.gz
gentoo-406a66aefc336cf90844a7a995fb35900277b70e.tar.bz2
gentoo-406a66aefc336cf90844a7a995fb35900277b70e.zip
dev-python/pywavelets: clean doc generation
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pywavelets')
-rw-r--r--dev-python/pywavelets/pywavelets-1.1.1.ebuild16
1 files changed, 5 insertions, 11 deletions
diff --git a/dev-python/pywavelets/pywavelets-1.1.1.ebuild b/dev-python/pywavelets/pywavelets-1.1.1.ebuild
index ac3571d385b5..01198d7e30ca 100644
--- a/dev-python/pywavelets/pywavelets-1.1.1.ebuild
+++ b/dev-python/pywavelets/pywavelets-1.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,15 +14,14 @@ DESCRIPTION="Discrete Wavelet Transforms in Python"
HOMEPAGE="https://pywavelets.readthedocs.io/en/latest/
https://github.com/PyWavelets/pywt"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
+IUSE="examples"
RDEPEND="
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}] )
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
"
@@ -31,19 +30,14 @@ BDEPEND="${RDEPEND}
"
distutils_enable_tests pytest
-
-S="${WORKDIR}/${MY_P}"
+distutils_enable_sphinx doc/source \
+ dev-python/numpydoc
python_test() {
pytest -vv --pyargs ${BUILD_DIR}"/lib" || die "Tests fail with ${EPYTHON}"
}
-python_compile_all() {
- use doc && emake -C doc html
-}
-
python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
distutils-r1_python_install_all
if use examples; then
docinto examples