summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-07-25 09:50:59 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-07-25 09:50:59 +0200
commit6ad0577b3b438d038f5d701f4054189e46eaeba2 (patch)
tree3fa4215b4920b306241b696e925a11dcd262919c /dev-python/pyxattr
parentdev-python/pyxattr: Bump to version 0.6.1 (diff)
downloadgentoo-6ad0577b3b438d038f5d701f4054189e46eaeba2.tar.gz
gentoo-6ad0577b3b438d038f5d701f4054189e46eaeba2.tar.bz2
gentoo-6ad0577b3b438d038f5d701f4054189e46eaeba2.zip
dev-python/pyxattr: Removed old.
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-python/pyxattr')
-rw-r--r--dev-python/pyxattr/Manifest1
-rw-r--r--dev-python/pyxattr/pyxattr-0.5.5.ebuild55
-rw-r--r--dev-python/pyxattr/pyxattr-0.6.0.ebuild55
3 files changed, 0 insertions, 111 deletions
diff --git a/dev-python/pyxattr/Manifest b/dev-python/pyxattr/Manifest
index a1cb6f2df3eb..8ed6308474ac 100644
--- a/dev-python/pyxattr/Manifest
+++ b/dev-python/pyxattr/Manifest
@@ -1,3 +1,2 @@
-DIST pyxattr-0.5.5.tar.gz 26718 BLAKE2B b8d599ed0194fec4809ebdb8277fa4023e932ed49a8a6253a7c6a879250a73330334bd8a72b0c9d9bfd828cac1454659d23b55b5e608bfe0109392988709beb8 SHA512 77b732a7e524a7c31a0511df2c96c18b214f93c6ac47276ecdf12ed95133ee506fa882b2532a7159aa2f4e02a7128e33bb8883ea632a5394297d98fb28898327
DIST pyxattr-0.6.0.tar.gz 31057 BLAKE2B cf6e99c499dbcc74305970413803e5cf59508e7ee1bf247afe42e576c2dfaf118a374ad6f8721b9d9c482f8be0c222d26b82997dc1ccc79248d5f52b2064ed8d SHA512 c56bf57729b5f8c8e3e19e29fd903b7365c6644abe3dcebf57ffc2f97a1e92d0e22cdc0a967c5abee3a74ba61a2a379e31a1734f45449095bdb7895b8357a9bb
DIST pyxattr-0.6.1.tar.gz 32105 BLAKE2B 0334d056ea652492fcc7958e0caf0ec438253e287c3f2ee663c0eb059fad5f01bba02963fc90035f84c129e19ee08e11bbc5573cebef6fd7ffe5c65adddc02ab SHA512 2c2defee81e2bd7e7e7f67d33676858f27494f12ba5c3d34bd548912a058cae562e9e9ed0dc5697892d1d55c29f2a5e10455260092b63faa54e40b841c42681d
diff --git a/dev-python/pyxattr/pyxattr-0.5.5.ebuild b/dev-python/pyxattr/pyxattr-0.5.5.ebuild
deleted file mode 100644
index 443601b32e01..000000000000
--- a/dev-python/pyxattr/pyxattr-0.5.5.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Python interface to xattr"
-HOMEPAGE="https://pyxattr.k1024.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
- https://pyxattr.k1024.org/downloads/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="sys-apps/attr"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- sed -i -e 's:, "-Werror"::' setup.py || die
- # Bug 548486
- sed -e "s:html_theme = 'default':html_theme = 'classic':" \
- -i doc/conf.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake doc
-}
-
-src_test() {
- # Perform the tests in /var/tmp; that location is more likely
- # to have xattr support than /tmp which is often tmpfs.
- export TESTDIR=/var/tmp
-
- einfo 'Please note that the tests fail if xattrs are not supported'
- einfo 'by the filesystem used for /var/tmp.'
- distutils-r1_src_test
-}
-
-python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pyxattr/pyxattr-0.6.0.ebuild b/dev-python/pyxattr/pyxattr-0.6.0.ebuild
deleted file mode 100644
index daa8071fc78c..000000000000
--- a/dev-python/pyxattr/pyxattr-0.6.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Python interface to xattr"
-HOMEPAGE="https://pyxattr.k1024.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
- https://pyxattr.k1024.org/downloads/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="sys-apps/attr"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- sed -i -e 's:, "-Werror"::' setup.py || die
- # Bug 548486
- sed -e "s:html_theme = 'default':html_theme = 'classic':" \
- -i doc/conf.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake doc
-}
-
-src_test() {
- # Perform the tests in /var/tmp; that location is more likely
- # to have xattr support than /tmp which is often tmpfs.
- export TESTDIR=/var/tmp
-
- einfo 'Please note that the tests fail if xattrs are not supported'
- einfo 'by the filesystem used for /var/tmp.'
- distutils-r1_src_test
-}
-
-python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/html/. )
- distutils-r1_python_install_all
-}