summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-29 21:34:50 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-29 21:35:06 -0400
commitf7e7342f84fbaca8640ca8941e6d07202955848f (patch)
tree8e983a5a67aea75c066f6261419ba5fd9c2db960 /dev-python/pyyaml/pyyaml-3.12.ebuild
parentapp-text/convertlit: new revision supporting $(AR). (diff)
downloadgentoo-f7e7342f84fbaca8640ca8941e6d07202955848f.tar.gz
gentoo-f7e7342f84fbaca8640ca8941e6d07202955848f.tar.bz2
gentoo-f7e7342f84fbaca8640ca8941e6d07202955848f.zip
dev-python/pyyaml: version bump to 3.12
Diffstat (limited to 'dev-python/pyyaml/pyyaml-3.12.ebuild')
-rw-r--r--dev-python/pyyaml/pyyaml-3.12.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyyaml/pyyaml-3.12.ebuild b/dev-python/pyyaml/pyyaml-3.12.ebuild
new file mode 100644
index 000000000000..b6965b856206
--- /dev/null
+++ b/dev-python/pyyaml/pyyaml-3.12.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_P="PyYAML-${PV}"
+
+DESCRIPTION="YAML parser and emitter for Python"
+HOMEPAGE="http://pyyaml.org/wiki/PyYAML https://pypi.python.org/pypi/PyYAML"
+SRC_URI="http://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="examples libyaml"
+
+RDEPEND="libyaml? ( dev-libs/libyaml )"
+DEPEND="${RDEPEND}
+ libyaml? ( $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' python2_7 'python3*') )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_configure_all() {
+ mydistutilsargs=( $(use_with libyaml) )
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}
+ fi
+}