summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-07-15 00:30:55 +0200
committerMichał Górny <mgorny@gentoo.org>2018-07-15 00:44:41 +0200
commit00a8e2bf8e53d74b6ce20ce1540df6d1bfe883d4 (patch)
tree92828542e4879fb6d9b369b2a6b13066b628bb9f /dev-python/pyyaml
parentsys-fs/mac-fdisk: workaround link failure on gcc-7 (diff)
downloadgentoo-00a8e2bf8e53d74b6ce20ce1540df6d1bfe883d4.tar.gz
gentoo-00a8e2bf8e53d74b6ce20ce1540df6d1bfe883d4.tar.bz2
gentoo-00a8e2bf8e53d74b6ce20ce1540df6d1bfe883d4.zip
dev-python/pyyaml: Bump to 3.13
Diffstat (limited to 'dev-python/pyyaml')
-rw-r--r--dev-python/pyyaml/Manifest1
-rw-r--r--dev-python/pyyaml/pyyaml-3.13.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyyaml/Manifest b/dev-python/pyyaml/Manifest
index 8a902317b550..b3a40935b37f 100644
--- a/dev-python/pyyaml/Manifest
+++ b/dev-python/pyyaml/Manifest
@@ -1 +1,2 @@
DIST PyYAML-3.12.tar.gz 253011 BLAKE2B 530f2910acb757af9e2a738d93ace45daee3fc5764f19fbc758508e873f05ebfa2486c4f82800540e5e405e7f114f06f963e5011908fd15014ca8b8afb3a76aa SHA512 e16d8b7f4f026b6a95b11fb59c54ec5f114f6f516294eaa95e718abdf5d37c17a9c4b5e0a0a61fca04e801792d9b7fb801087cf849ff22b9581f6af204b1883a
+DIST PyYAML-3.13.tar.gz 270607 BLAKE2B f365f63587b911234497426c9796f98b85f5de052abd88ea434137a4eb8a4c1e08f9ee1982a30df1934dadb615145f4af8fcff577d3d4e52058e7a8843aa8604 SHA512 93642286d0317e2fe970632c36d38ce6030f7cabcf971f28e3a1054f07390fcee5baaf7f167e7c9690dbd7b2adc61f5b7d75a218ace0abca34ff8815486cfdd7
diff --git a/dev-python/pyyaml/pyyaml-3.13.ebuild b/dev-python/pyyaml/pyyaml-3.13.ebuild
new file mode 100644
index 000000000000..91ad0a5c141c
--- /dev/null
+++ b/dev-python/pyyaml/pyyaml-3.13.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_P="PyYAML-${PV}"
+
+DESCRIPTION="YAML parser and emitter for Python"
+HOMEPAGE="https://pyyaml.org/wiki/PyYAML https://pypi.org/project/PyYAML/"
+SRC_URI="https://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="examples libyaml"
+
+RDEPEND="libyaml? ( dev-libs/libyaml )"
+DEPEND="${RDEPEND}
+ libyaml? ( $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' python2_7 'python3*') )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_configure_all() {
+ mydistutilsargs=( $(use_with libyaml) )
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}
+ fi
+}