summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-20 01:35:12 +0000
committerSam James <sam@gentoo.org>2021-01-20 01:35:12 +0000
commite095455ebcf69605fe4f34332176da8198e7e333 (patch)
treeda5730c0807b982feed6c987a960b74572bca8d7 /dev-python/pyyaml
parentx11-wm/awesome: Stabilize 4.3-r2 ppc64, #763861 (diff)
downloadgentoo-e095455ebcf69605fe4f34332176da8198e7e333.tar.gz
gentoo-e095455ebcf69605fe4f34332176da8198e7e333.tar.bz2
gentoo-e095455ebcf69605fe4f34332176da8198e7e333.zip
dev-python/pyyaml: security bump to 5.4
Bug: https://bugs.gentoo.org/766228 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pyyaml')
-rw-r--r--dev-python/pyyaml/Manifest1
-rw-r--r--dev-python/pyyaml/pyyaml-5.4.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pyyaml/Manifest b/dev-python/pyyaml/Manifest
index 360375ff2813..78896f1cf487 100644
--- a/dev-python/pyyaml/Manifest
+++ b/dev-python/pyyaml/Manifest
@@ -1 +1,2 @@
DIST pyyaml-5.3.1.gh.tar.gz 168044 BLAKE2B 2acc62ecc7448925eb340c2555001c8a74bd883d720b992d6deaea890b4eac435e4ae02eb129db3a6778c0be21a231fa9d96ee8ae59a4a39bc49961e5fb0d6ab SHA512 27d97e8493c7660c7c0c471e20a8aa46c85431e4559a98bcbdafc2bd89a67fd04c6f2090e54ff6b206c868b33635ef8be68070a4c25d17a25c97fd5ad3549556
+DIST pyyaml-5.4.gh.tar.gz 173140 BLAKE2B 2ff298cce44442b8431197b9222c2fba18d4f0aaf600fe636174864096f49f1392c3e965155b36c94ad0cf659402ffbd660cea5719b509bf90e9f316c1893248 SHA512 a76f9cf1838380b2e509bf1d5251f175cca1b413aadc511517de5fb3b4743747918f94abc1cf1976171731a1ba67596def3cb0652d08e1e3af3235cf7c0a610f
diff --git a/dev-python/pyyaml/pyyaml-5.4.ebuild b/dev-python/pyyaml/pyyaml-5.4.ebuild
new file mode 100644
index 000000000000..cb18eff64ebb
--- /dev/null
+++ b/dev-python/pyyaml/pyyaml-5.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="YAML parser and emitter for Python"
+HOMEPAGE="https://pyyaml.org/wiki/PyYAML
+ https://pypi.org/project/PyYAML/
+ https://github.com/yaml/pyyaml"
+SRC_URI="https://github.com/yaml/pyyaml/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE="examples +libyaml"
+
+BDEPEND="
+ libyaml? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+RDEPEND="libyaml? ( dev-libs/libyaml:= )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ # bug #659348
+ "${FILESDIR}/pyyaml-5.1-cve-2017-18342.patch"
+)
+
+distutils_enable_tests setup.py
+
+python_configure_all() {
+ mydistutilsargs=( $(use_with libyaml) )
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}
+ fi
+}