summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-22 09:08:27 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-22 09:08:27 +0200
commit4ac180562524a37ee5770cbda6a27077bc16884c (patch)
tree28aac838f83a92652c0e3efc031fb5c850978b4f /dev-python/qtconsole
parentdev-python/qscintilla-python: Remove redundant versions (diff)
downloadgentoo-4ac180562524a37ee5770cbda6a27077bc16884c.tar.gz
gentoo-4ac180562524a37ee5770cbda6a27077bc16884c.tar.bz2
gentoo-4ac180562524a37ee5770cbda6a27077bc16884c.zip
dev-python/qtconsole: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/qtconsole')
-rw-r--r--dev-python/qtconsole/Manifest2
-rw-r--r--dev-python/qtconsole/qtconsole-4.3.1.ebuild67
-rw-r--r--dev-python/qtconsole/qtconsole-4.7.4.ebuild46
3 files changed, 0 insertions, 115 deletions
diff --git a/dev-python/qtconsole/Manifest b/dev-python/qtconsole/Manifest
index 07835d04d331..5b892325ced7 100644
--- a/dev-python/qtconsole/Manifest
+++ b/dev-python/qtconsole/Manifest
@@ -1,4 +1,2 @@
-DIST qtconsole-4.3.1.tar.gz 416931 BLAKE2B ec47c2ae8527d7aee55d6cb8d2ebea39ab1bfd3a268c46306613b67f72c27904db1de52682a47d075d804dad9cd7c124296163b39532936fb1a497ae606b7ffc SHA512 f0f84d95143b4513c3d12af4712c6a5724143bf8c44e7a3fbc06d7a94e665b8d12072dd13eafb09476a3aa829155f4c75eb517ffb2bd6e8bd3c00af3c764e48f
-DIST qtconsole-4.7.4.tar.gz 424884 BLAKE2B 79380a1619498a28eaf7e741a3408a63b58705fe7c0672108b57c5cd9bb7c35d77569ce59a3cdb8dc21b3e403cc41845a534c55838ecf2e82038677132e90fbb SHA512 4564c0ee15b1feaff235ae35a22bfb719497e5f74416ea0ab471018c4d68e13dd05cc4d0180b69151f81817180d4985589340698067b5a2166764a39147255fa
DIST qtconsole-4.7.5.tar.gz 424850 BLAKE2B e2d2ba50ce57b13504bdf8ad1ee3374b76abc980f0b74dfe1177c3f066ba24382bc51f8d3db2614a8d74b198ed20f01fac67c288602ae6e31fe90165e63ab9e9 SHA512 ee57ad2de5b840ee4e7f439be08a3c82fd39ef1bf6113b7eda95fa1aabd132c799ff584a2ac7f7e2c89df4bcd9a9409bbaeee108a6bb49e6197d2e3395336ad7
DIST qtconsole-4.7.6.tar.gz 424919 BLAKE2B d973b3b94dfad1b38603695e22927bcdcb8a4f2db9f4a638d5fe6a83c24061153dbaa36c26e632708953af32a015af1d40ecbf175dd5314a3b954b15a6625cc0 SHA512 e4e12eb90533e922786b5b6517fba5d9c4dfedf00547f1403c8cd65fb464f5c1a13517df69924e4428e9a8a811dfc359a7768fbaa90adbe02d79cba9a5aa852e
diff --git a/dev-python/qtconsole/qtconsole-4.3.1.ebuild b/dev-python/qtconsole/qtconsole-4.3.1.ebuild
deleted file mode 100644
index 7e9a961abd2b..000000000000
--- a/dev-python/qtconsole/qtconsole-4.3.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE="threads(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
-HOMEPAGE="https://qtconsole.readthedocs.io"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/ipython_genutils[${PYTHON_USEDEP}]
- dev-python/jupyter_core[${PYTHON_USEDEP}]
- >=dev-python/jupyter_client-4.1.1[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- doc? (
- >=dev-python/ipython-4.0.0-r2[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.3.1-r1[${PYTHON_USEDEP}]
- )
- test? (
- >=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
- dev-python/PyQt5[${PYTHON_USEDEP},svg,testlib]
- )
- dev-python/PyQt5[${PYTHON_USEDEP},svg]
- dev-python/pygments[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-13[${PYTHON_USEDEP}]
- "
-PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/build/html/. )
- fi
-}
-
-python_test() {
- # jupyter qtconsole --generate-config ... jupyter-qtconsole: cannot connect to X server
- # ERROR
- sed \
- -e 's:test_generate_config:_&:g' \
- -i qtconsole/tests/test_app.py || die
- virtx nosetests --verbosity=2 qtconsole
-}
diff --git a/dev-python/qtconsole/qtconsole-4.7.4.ebuild b/dev-python/qtconsole/qtconsole-4.7.4.ebuild
deleted file mode 100644
index bb804024a85d..000000000000
--- a/dev-python/qtconsole/qtconsole-4.7.4.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-PYTHON_REQ_USE="threads(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
-HOMEPAGE="https://qtconsole.readthedocs.io"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-
-RDEPEND="
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/ipython_genutils[${PYTHON_USEDEP}]
- dev-python/jupyter_core[${PYTHON_USEDEP}]
- >=dev-python/jupyter_client-4.1.1[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
- dev-python/QtPy[${PYTHON_USEDEP},svg]
-"
-BDEPEND="
- test? (
- dev-python/QtPy[${PYTHON_USEDEP},svg,testlib]
- )
-"
-# required by removed tests:
-# dev-python/pytest-qt[${PYTHON_USEDEP}]
-PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx docs/source
-distutils_enable_tests pytest
-
-src_prepare() {
- # TODO: these tests require virtx; however, running under virtx
- # causes pytest to segv on exit (even though tests pass)
- rm qtconsole/tests/test_00_console_widget.py || die
- distutils-r1_src_prepare
-}