summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-27 19:51:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-27 19:52:22 +0300
commit78f1e8999a8ca59dab5e4789f505013fca14f2d4 (patch)
tree0b4d7327d343697e088d514833ce96b045d4181f /dev-python/qtsass
parentLinux-info.eclass : Fix typo in comment (diff)
downloadgentoo-78f1e8999a8ca59dab5e4789f505013fca14f2d4.tar.gz
gentoo-78f1e8999a8ca59dab5e4789f505013fca14f2d4.tar.bz2
gentoo-78f1e8999a8ca59dab5e4789f505013fca14f2d4.zip
dev-python/qtsass: enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/qtsass')
-rw-r--r--dev-python/qtsass/files/qtsass-0.3.0-fix-py3.10.patch37
-rw-r--r--dev-python/qtsass/qtsass-0.3.0.ebuild18
2 files changed, 47 insertions, 8 deletions
diff --git a/dev-python/qtsass/files/qtsass-0.3.0-fix-py3.10.patch b/dev-python/qtsass/files/qtsass-0.3.0-fix-py3.10.patch
new file mode 100644
index 000000000000..4aa3342170e4
--- /dev/null
+++ b/dev-python/qtsass/files/qtsass-0.3.0-fix-py3.10.patch
@@ -0,0 +1,37 @@
+From cbea8d8729282106373a12b9e08bcaac8abeb52f Mon Sep 17 00:00:00 2001
+From: goanpeca <goanpeca@gmail.com>
+Date: Tue, 24 Mar 2020 11:51:28 -0500
+Subject: [PATCH] Add check for deprecated api between 2 and 3 versions
+
+---
+ qtsass/api.py | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/qtsass/api.py b/qtsass/api.py
+index 7ea4138..7a65fe2 100644
+--- a/qtsass/api.py
++++ b/qtsass/api.py
+@@ -13,9 +13,9 @@
+ from __future__ import absolute_import, print_function
+
+ # Standard library imports
+-from collections import Mapping, Sequence
+ import logging
+ import os
++import sys
+
+ # Third party imports
+ import sass
+@@ -26,6 +26,12 @@
+ from qtsass.importers import qss_importer
+
+
++if sys.version_info[0] == 3:
++ from collections.abc import Mapping, Sequence
++else:
++ from collections import Mapping, Sequence
++
++
+ # yapf: enable
+
+ # Constants
diff --git a/dev-python/qtsass/qtsass-0.3.0.ebuild b/dev-python/qtsass/qtsass-0.3.0.ebuild
index 3409b05d8082..ef7668b644df 100644
--- a/dev-python/qtsass/qtsass-0.3.0.ebuild
+++ b/dev-python/qtsass/qtsass-0.3.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
@@ -17,13 +17,15 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
-DEPEND="dev-python/libsass[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/libsass[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.10.patch"
+)
distutils_enable_tests pytest
-python_prepare_all() {
+EPYTEST_DESELECT=(
# assert 1 == 2
- sed -i -e 's:test_watchers:_&:' tests/test_watchers.py || die
-
- distutils-r1_python_prepare_all
-}
+ tests/test_watchers.py::test_watchers
+)