summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2020-08-09 13:33:37 +0200
committerAlfredo Tupone <tupone@gentoo.org>2020-08-09 13:33:37 +0200
commit850ec7729eef9ad9dbbe37be3d6f90f38e4c9754 (patch)
tree83b600bb2908cd43429458893fb821638166872c /dev-python/quex/quex-0.65.4-r1.ebuild
parentmedia-libs/ladspa-cmt: respecting CFLAGS in 1.17 (diff)
downloadgentoo-850ec7729eef9ad9dbbe37be3d6f90f38e4c9754.tar.gz
gentoo-850ec7729eef9ad9dbbe37be3d6f90f38e4c9754.tar.bz2
gentoo-850ec7729eef9ad9dbbe37be3d6f90f38e4c9754.zip
dev-python/quex: EAPI 7
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-python/quex/quex-0.65.4-r1.ebuild')
-rw-r--r--dev-python/quex/quex-0.65.4-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/quex/quex-0.65.4-r1.ebuild b/dev-python/quex/quex-0.65.4-r1.ebuild
new file mode 100644
index 000000000000..ad2be6628c06
--- /dev/null
+++ b/dev-python/quex/quex-0.65.4-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Mode Oriented Directly Coded Lexical Analyser Generator"
+HOMEPAGE="http://quex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="${RDEPEND}"
+DEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:@PYTHON_SITEDIR@:$(python_get_sitedir):g" \
+ quex/DEFINITIONS.py || die
+ mv quex/engine/codec_db/database . || die
+ mv quex/code_base . || die
+}
+
+src_install() {
+ default
+ insinto /usr/share/quex
+ doins -r database
+ doins -r code_base
+
+ python_domodule quex
+ python_newscript quex-exe.py quex
+ doman manpage/quex.1
+ dodoc -r demo
+ insinto /etc/profile.d/
+ doins "${FILESDIR}"/quex.sh
+}