summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/rackspace-monitoring-cli
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/rackspace-monitoring-cli')
-rw-r--r--dev-python/rackspace-monitoring-cli/Manifest2
-rw-r--r--dev-python/rackspace-monitoring-cli/metadata.xml16
-rw-r--r--dev-python/rackspace-monitoring-cli/rackspace-monitoring-cli-0.6.10.ebuild29
-rw-r--r--dev-python/rackspace-monitoring-cli/rackspace-monitoring-cli-0.6.9.ebuild29
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/rackspace-monitoring-cli/Manifest b/dev-python/rackspace-monitoring-cli/Manifest
new file mode 100644
index 000000000000..cc760787485b
--- /dev/null
+++ b/dev-python/rackspace-monitoring-cli/Manifest
@@ -0,0 +1,2 @@
+DIST rackspace-monitoring-cli-0.6.10.tar.gz 156395 SHA256 b3a4c418edd73ad3c281cc0ead19cdc4127791dd80986d6c8a802ce6513d97cf SHA512 538ba6667557e40eb1ab381a7be147805a6cfd46f10d51d30e38f35cfe18b9324f4fdfea051e22b083b510d0501c254c80b4914c07470db9e3a1de7d247d1403 WHIRLPOOL 1d5353d9ee3416b20493c9a068cc394ecf10144e39233b048c14e5f9affc736f5ee07eb0c43fc303184eddf566fa4a98f84a90cdaeec4a119137e1ea92147b79
+DIST rackspace-monitoring-cli-0.6.9.tar.gz 156113 SHA256 37a0c4f0efcbd736f4c3b73b6e728fd6a267d52ecbd449b18d3e7d2373b77cc9 SHA512 79fb2f56777fc3b7c3c5263e98adcc6ab5e44e112bcf69d72816d5bbcbeb5f1b63d55da1dce8b501ec0b801afaea70057e9fbb670db731514aca0d071d654ef8 WHIRLPOOL 663baf2a428fcfdeb512172f1767064e643cd0d05018386f5a63b7b97a5f040d0d5563ba028be53ef32e09756f2a557204acf1e64c86f0a5adbdd6b7e0308dbe
diff --git a/dev-python/rackspace-monitoring-cli/metadata.xml b/dev-python/rackspace-monitoring-cli/metadata.xml
new file mode 100644
index 000000000000..a2e2096eeb44
--- /dev/null
+++ b/dev-python/rackspace-monitoring-cli/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Command Line Utility for Rackspace Cloud Monitoring (MaaS)
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">rackspace-monitoring-cli</remote-id>
+ <remote-id type="github">racker/rackspace-monitoring-cli</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rackspace-monitoring-cli/rackspace-monitoring-cli-0.6.10.ebuild b/dev-python/rackspace-monitoring-cli/rackspace-monitoring-cli-0.6.10.ebuild
new file mode 100644
index 000000000000..06145723d73f
--- /dev/null
+++ b/dev-python/rackspace-monitoring-cli/rackspace-monitoring-cli-0.6.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+# https://github.com/racker/rackspace-monitoring-cli/issues/49
+RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Utility for Rackspace Cloud Monitoring (MaaS)"
+HOMEPAGE="https://github.com/racker/rackspace-monitoring-cli"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+TEST_DEPENDS="dev-python/pep8[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/rackspace-monitoring-0.6.5[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${TEST_DEPENDS} )"
+
+python_test() {
+ ${EPYTHON} setup.py pep8 || die
+}
diff --git a/dev-python/rackspace-monitoring-cli/rackspace-monitoring-cli-0.6.9.ebuild b/dev-python/rackspace-monitoring-cli/rackspace-monitoring-cli-0.6.9.ebuild
new file mode 100644
index 000000000000..06145723d73f
--- /dev/null
+++ b/dev-python/rackspace-monitoring-cli/rackspace-monitoring-cli-0.6.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+# https://github.com/racker/rackspace-monitoring-cli/issues/49
+RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Utility for Rackspace Cloud Monitoring (MaaS)"
+HOMEPAGE="https://github.com/racker/rackspace-monitoring-cli"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+TEST_DEPENDS="dev-python/pep8[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/rackspace-monitoring-0.6.5[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${TEST_DEPENDS} )"
+
+python_test() {
+ ${EPYTHON} setup.py pep8 || die
+}