summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-03-27 09:03:09 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-03-27 09:03:09 -0500
commit2c44ea84530404e11d31dee36774717f743465c6 (patch)
treef1797598e4d8bcfd1da29d53beff4fc7ab797405 /dev-python/radon
parentnet-analyzer/2ping: remove older versions (diff)
downloadgentoo-2c44ea84530404e11d31dee36774717f743465c6.tar.gz
gentoo-2c44ea84530404e11d31dee36774717f743465c6.tar.bz2
gentoo-2c44ea84530404e11d31dee36774717f743465c6.zip
dev-python/radon: add version 1.3.1
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/radon')
-rw-r--r--dev-python/radon/Manifest1
-rw-r--r--dev-python/radon/radon-1.3.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/radon/Manifest b/dev-python/radon/Manifest
index 778082ed4ee1..6b09e86bd7a8 100644
--- a/dev-python/radon/Manifest
+++ b/dev-python/radon/Manifest
@@ -1,3 +1,4 @@
DIST radon-1.2.1.tar.gz 1633366 SHA256 bacc94a4a5c1a3e9410944e8e4e0f0aaf7dcf066c9b35bd92ac8eba5d47429fa SHA512 5676695344b7cf574abd9079ee3856debdf3ac4bda4a1c52e00406e2bbb71ad74f320f43638887e30db073fd623070a97fc44c031eec13588e953b33b549e2bf WHIRLPOOL 2ab535d0fe0b56b538dbe389b68e522468611f25c797c69343f4da700ae6129dc725051998238f0f136c45382f29887cdccc899aeaab000796f22a9962d40505
DIST radon-1.2.2.tar.gz 3468244 SHA256 3cab798af062632ad275092c537e409f8948c19034e98d3ab243ce455b4eee9d SHA512 2bd424ca81fd55d1bf444e7b2a228bd11ee23a7f77cad488fa45e8ce888282373f1729f7f00ca2f19838e10bbc1dabb1602f5bbac396702b52309a60671ef0a7 WHIRLPOOL 46e549bd9d29cd7d54a4e9746ea67f541919fdb90769f1cb3b70b51420b85bacac024b6bc0c16f25f4257652f76d750892bf2eefb146ea0ae76ef7718de11781
DIST radon-1.2.tar.gz 1604458 SHA256 289ee3c5ef9e55fb159d589f5c0b20c2ce4f5aaa94502fe7c1d1a5fd444957c7 SHA512 9fe3a505d83b7c69a9adc98247063e91aed9f52187f2d33356a586dcf498492fb5acd283725dc9acd0f03dd1365cc3113925f027f0d0d94a94258b7ac217b62e WHIRLPOOL 5a613cce315feef10392a8fa8a7c2bc050fc35e8ee09b2d4b1afc9b72bae2887ed1d71a206fb1e9415548d554bc74bf52e8e0cc71eadd4be1d6791cb87eb96d7
+DIST radon-1.3.1.tar.gz 3472429 SHA256 292afbb0e4e489d0b52ea6ce6e34008f2c62e359969d9ef5967ffbd18ae210ba SHA512 21088696f29479ae188064ee3864ae8fdee3687b322f2b60ea8deeafca93e582b37b739e2251da6cd47c18a67fbb527acb6293233652dc8993224ba7cc471d8c WHIRLPOOL 32806fd18bfd5f26148cc78f412179c4f5395d4af1548a61851b957d89eddaef466fff220231fbb17c3f41e0be15cb4a3d9196af67811edadf2b0b67e0f28ee6
diff --git a/dev-python/radon/radon-1.3.1.ebuild b/dev-python/radon/radon-1.3.1.ebuild
new file mode 100644
index 000000000000..64950fcccfa3
--- /dev/null
+++ b/dev-python/radon/radon-1.3.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Code Metrics in Python"
+HOMEPAGE="https://radon.readthedocs.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RCDEPEND="
+ >=dev-python/colorama-0.3[${PYTHON_USEDEP}]
+ <dev-python/colorama-0.4[${PYTHON_USEDEP}]
+ >=dev-python/mando-0.3[${PYTHON_USEDEP}]
+ <dev-python/mando-0.4[${PYTHON_USEDEP}]
+"
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ ${CDEPEND}
+ test? (
+ ${RCDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/paramunittest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ ${RCDEPEND}
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" radon/tests/run.py || die "tests failed to run under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}