summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/radon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/radon')
-rw-r--r--dev-python/radon/Manifest3
-rw-r--r--dev-python/radon/metadata.xml14
-rw-r--r--dev-python/radon/radon-1.2.1.ebuild51
-rw-r--r--dev-python/radon/radon-1.2.2.ebuild51
-rw-r--r--dev-python/radon/radon-1.2.ebuild47
5 files changed, 166 insertions, 0 deletions
diff --git a/dev-python/radon/Manifest b/dev-python/radon/Manifest
new file mode 100644
index 000000000000..778082ed4ee1
--- /dev/null
+++ b/dev-python/radon/Manifest
@@ -0,0 +1,3 @@
+DIST radon-1.2.1.tar.gz 1633366 SHA256 bacc94a4a5c1a3e9410944e8e4e0f0aaf7dcf066c9b35bd92ac8eba5d47429fa SHA512 5676695344b7cf574abd9079ee3856debdf3ac4bda4a1c52e00406e2bbb71ad74f320f43638887e30db073fd623070a97fc44c031eec13588e953b33b549e2bf WHIRLPOOL 2ab535d0fe0b56b538dbe389b68e522468611f25c797c69343f4da700ae6129dc725051998238f0f136c45382f29887cdccc899aeaab000796f22a9962d40505
+DIST radon-1.2.2.tar.gz 3468244 SHA256 3cab798af062632ad275092c537e409f8948c19034e98d3ab243ce455b4eee9d SHA512 2bd424ca81fd55d1bf444e7b2a228bd11ee23a7f77cad488fa45e8ce888282373f1729f7f00ca2f19838e10bbc1dabb1602f5bbac396702b52309a60671ef0a7 WHIRLPOOL 46e549bd9d29cd7d54a4e9746ea67f541919fdb90769f1cb3b70b51420b85bacac024b6bc0c16f25f4257652f76d750892bf2eefb146ea0ae76ef7718de11781
+DIST radon-1.2.tar.gz 1604458 SHA256 289ee3c5ef9e55fb159d589f5c0b20c2ce4f5aaa94502fe7c1d1a5fd444957c7 SHA512 9fe3a505d83b7c69a9adc98247063e91aed9f52187f2d33356a586dcf498492fb5acd283725dc9acd0f03dd1365cc3113925f027f0d0d94a94258b7ac217b62e WHIRLPOOL 5a613cce315feef10392a8fa8a7c2bc050fc35e8ee09b2d4b1afc9b72bae2887ed1d71a206fb1e9415548d554bc74bf52e8e0cc71eadd4be1d6791cb87eb96d7
diff --git a/dev-python/radon/metadata.xml b/dev-python/radon/metadata.xml
new file mode 100644
index 000000000000..b8a320733254
--- /dev/null
+++ b/dev-python/radon/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">radon</remote-id>
+ <remote-id type="github">rubik/radon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/radon/radon-1.2.1.ebuild b/dev-python/radon/radon-1.2.1.ebuild
new file mode 100644
index 000000000000..6eaa063c3809
--- /dev/null
+++ b/dev-python/radon/radon-1.2.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Code Metrics in Python"
+HOMEPAGE="https://radon.readthedocs.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RCDEPEND="
+ dev-python/mando[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+"
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ ${CDEPEND}
+ test? (
+ ${RCDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/paramunittest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ ${RCDEPEND}
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" radon/tests/run.py || die "tests failed to run under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/radon/radon-1.2.2.ebuild b/dev-python/radon/radon-1.2.2.ebuild
new file mode 100644
index 000000000000..6eaa063c3809
--- /dev/null
+++ b/dev-python/radon/radon-1.2.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Code Metrics in Python"
+HOMEPAGE="https://radon.readthedocs.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RCDEPEND="
+ dev-python/mando[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+"
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ ${CDEPEND}
+ test? (
+ ${RCDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/paramunittest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ ${RCDEPEND}
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" radon/tests/run.py || die "tests failed to run under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/radon/radon-1.2.ebuild b/dev-python/radon/radon-1.2.ebuild
new file mode 100644
index 000000000000..fb47f75eaa11
--- /dev/null
+++ b/dev-python/radon/radon-1.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Code Metrics in Python"
+HOMEPAGE="https://radon.readthedocs.org/"
+SRC_URI="https://github.com/rubik/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="
+ dev-python/mando[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/paramunittest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" radon/tests/run.py || die "tests failed to run under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}