summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-06-11 10:24:12 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-06-11 10:24:12 -0500
commitfa8650bcb36734c7a23bc8719ee0753dbfc50fc1 (patch)
tree3de37bbc3aa28baa0b18e10a6fb5726a8e556982 /dev-python/radon
parentdev-python/botocore: remove version 1.4.17 (diff)
downloadgentoo-fa8650bcb36734c7a23bc8719ee0753dbfc50fc1.tar.gz
gentoo-fa8650bcb36734c7a23bc8719ee0753dbfc50fc1.tar.bz2
gentoo-fa8650bcb36734c7a23bc8719ee0753dbfc50fc1.zip
dev-python/radon: add version 1.4.0
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/radon')
-rw-r--r--dev-python/radon/Manifest1
-rw-r--r--dev-python/radon/radon-1.4.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/radon/Manifest b/dev-python/radon/Manifest
index d503c1be3138..b58e53ae38f9 100644
--- a/dev-python/radon/Manifest
+++ b/dev-python/radon/Manifest
@@ -1,3 +1,4 @@
DIST radon-1.2.2.tar.gz 3468244 SHA256 3cab798af062632ad275092c537e409f8948c19034e98d3ab243ce455b4eee9d SHA512 2bd424ca81fd55d1bf444e7b2a228bd11ee23a7f77cad488fa45e8ce888282373f1729f7f00ca2f19838e10bbc1dabb1602f5bbac396702b52309a60671ef0a7 WHIRLPOOL 46e549bd9d29cd7d54a4e9746ea67f541919fdb90769f1cb3b70b51420b85bacac024b6bc0c16f25f4257652f76d750892bf2eefb146ea0ae76ef7718de11781
DIST radon-1.3.1.tar.gz 3472429 SHA256 292afbb0e4e489d0b52ea6ce6e34008f2c62e359969d9ef5967ffbd18ae210ba SHA512 21088696f29479ae188064ee3864ae8fdee3687b322f2b60ea8deeafca93e582b37b739e2251da6cd47c18a67fbb527acb6293233652dc8993224ba7cc471d8c WHIRLPOOL 32806fd18bfd5f26148cc78f412179c4f5395d4af1548a61851b957d89eddaef466fff220231fbb17c3f41e0be15cb4a3d9196af67811edadf2b0b67e0f28ee6
DIST radon-1.3.2.tar.gz 3454351 SHA256 2f8f70f9d445ddf9327c750a36ecd0231ced8bc80271333a980368ec282ab69d SHA512 60857e82742c2d1ecb2ddf9a1ffdd23066ca5ad4939ee7afe07b0309385000fb7ba8d69ae58b00174f0ec2f758ed40ccf0677e56e2904fa6d5220a4bb6d31e21 WHIRLPOOL 4aba7ab2a831ed693349f42b9371c1af9f3192e7f93f6e660d19d1d9b9fd0f5c4d91ef54be53a1d333d4b65a0d91586de10050117162ac090d18477e7dd8a8c7
+DIST radon-1.4.0.tar.gz 1645229 SHA256 a9f9171e69b6b57d5f8e58f89c76a79d7e09d790cc8fff0f95cd4c946e8cee8e SHA512 85612cfebfb07c8dd3b7c11b920fbe765cb28142bbf9ba5e787a2c4c1b248aab84bfc5d40236535d0943e78fee30c5feb373980ccc91b701cc7d3216d1b8a2b3 WHIRLPOOL e9b9dd1e97ca5e573ef130ccc9a38c38b0c033ebbee142cfeaf6d058d3691ba7923afd0b7eb4748e03752e47c59d5368a3954a5d76db1ee5e69e41cc7012020f
diff --git a/dev-python/radon/radon-1.4.0.ebuild b/dev-python/radon/radon-1.4.0.ebuild
new file mode 100644
index 000000000000..64950fcccfa3
--- /dev/null
+++ b/dev-python/radon/radon-1.4.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Code Metrics in Python"
+HOMEPAGE="https://radon.readthedocs.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RCDEPEND="
+ >=dev-python/colorama-0.3[${PYTHON_USEDEP}]
+ <dev-python/colorama-0.4[${PYTHON_USEDEP}]
+ >=dev-python/mando-0.3[${PYTHON_USEDEP}]
+ <dev-python/mando-0.4[${PYTHON_USEDEP}]
+"
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ ${CDEPEND}
+ test? (
+ ${RCDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/paramunittest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ ${RCDEPEND}
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" radon/tests/run.py || die "tests failed to run under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}