summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-08-09 15:17:12 -0700
committerBrian Dolbec <dolsen@gentoo.org>2016-08-09 16:47:21 -0700
commitc1a8f12c0daff4a971212f39381b6f8f42e2a580 (patch)
tree201851f33ed1a9d6919e7b58d6a22ba6fe79ac75 /dev-python/ramlfications/ramlfications-0.1.9.ebuild
parentdev-python/txgithub: New package, dep of buildbot-0.9 (diff)
downloadgentoo-c1a8f12c0daff4a971212f39381b6f8f42e2a580.tar.gz
gentoo-c1a8f12c0daff4a971212f39381b6f8f42e2a580.tar.bz2
gentoo-c1a8f12c0daff4a971212f39381b6f8f42e2a580.zip
dev-python/ramlfications: New package, dep og buildbot-0.9
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/ramlfications/ramlfications-0.1.9.ebuild')
-rw-r--r--dev-python/ramlfications/ramlfications-0.1.9.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/ramlfications/ramlfications-0.1.9.ebuild b/dev-python/ramlfications/ramlfications-0.1.9.ebuild
new file mode 100644
index 000000000000..44d8fe5806bf
--- /dev/null
+++ b/dev-python/ramlfications/ramlfications-0.1.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 pypy)
+
+inherit eutils distutils-r1
+
+DESCRIPTION="RAML reference implementation in Python"
+HOMEPAGE="https://ramlfications.readthedocs.org/ https://pypi.python.org/pypi/ramlfications/"
+SRC_URI="https://github.com/spotify/${PN}/releases/download/0.1.9/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/markdown2[${PYTHON_USEDEP}]
+ dev-python/jsonref[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"