summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-04-06 15:14:54 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-05-15 19:07:08 -0700
commite8367daa79a7a511d177febaa70212f4d216d157 (patch)
tree8bc0e326e5c5577920a0300caa1b45d2f427770a /dev-python/ramlfications/ramlfications-0.1.9_p20160718.ebuild
parentdev-python/venusian: Version bump, fix tests (diff)
downloadgentoo-e8367daa79a7a511d177febaa70212f4d216d157.tar.gz
gentoo-e8367daa79a7a511d177febaa70212f4d216d157.tar.bz2
gentoo-e8367daa79a7a511d177febaa70212f4d216d157.zip
dev-python/ramlfications: Version bump, to latest git commit
Needed to pass tests with python-3.5. Remove unused test use flag and deps in the 0.19 release. Package-Manager: Portage-2.3.5, Repoman-2.3.2_p30
Diffstat (limited to 'dev-python/ramlfications/ramlfications-0.1.9_p20160718.ebuild')
-rw-r--r--dev-python/ramlfications/ramlfications-0.1.9_p20160718.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/ramlfications/ramlfications-0.1.9_p20160718.ebuild b/dev-python/ramlfications/ramlfications-0.1.9_p20160718.ebuild
new file mode 100644
index 000000000000..da6490e25cb7
--- /dev/null
+++ b/dev-python/ramlfications/ramlfications-0.1.9_p20160718.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5})
+
+COMMIT="32a11cd7d75c4c5b3e3fc01c383314be298b0f9b"
+
+inherit eutils distutils-r1
+
+DESCRIPTION="RAML reference implementation in Python"
+HOMEPAGE="https://ramlfications.readthedocs.org/ https://pypi.python.org/pypi/ramlfications/"
+SRC_URI="https://github.com/spotify/${PN}/archive/${COMMIT}.zip -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/markdown2[${PYTHON_USEDEP}]
+ dev-python/jsonref[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}