summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-29 21:32:21 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-29 21:32:21 +0300
commitd5e4c1d38a0d88f1a8d5c4c0be53999d20fb9540 (patch)
tree2de1f3ce3af9c5c5bebf4a30baeea497488dbedf /dev-python/ratelimit
parentdev-python/rencode: enable py3.11 (diff)
downloadgentoo-d5e4c1d38a0d88f1a8d5c4c0be53999d20fb9540.tar.gz
gentoo-d5e4c1d38a0d88f1a8d5c4c0be53999d20fb9540.tar.bz2
gentoo-d5e4c1d38a0d88f1a8d5c4c0be53999d20fb9540.zip
dev-python/ratelimit: Use pep517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/ratelimit')
-rw-r--r--dev-python/ratelimit/ratelimit-2.2.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/ratelimit/ratelimit-2.2.1-r1.ebuild b/dev-python/ratelimit/ratelimit-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..5bac32d2843f
--- /dev/null
+++ b/dev-python/ratelimit/ratelimit-2.2.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="An API rate limit decorator for Python"
+HOMEPAGE="https://github.com/tomasbasham/ratelimit"
+SRC_URI="
+ https://github.com/tomasbasham/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove --cov args injection
+ rm pytest.ini || die
+ distutils-r1_src_prepare
+}