summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-08-19 18:01:31 +0800
committerIan Delaney <idella4@gentoo.org>2015-08-19 18:05:32 +0800
commite6bd20e91370b305de7765965d657742785855fc (patch)
tree14326f78eeacac23209c44865185fe8e0c3102c2 /dev-python/rdflib/rdflib-4.1.2.ebuild
parentdev-python/rdflib: take out doctests from test phase, fixes Bug #358189 (diff)
downloadgentoo-e6bd20e91370b305de7765965d657742785855fc.tar.gz
gentoo-e6bd20e91370b305de7765965d657742785855fc.tar.bz2
gentoo-e6bd20e91370b305de7765965d657742785855fc.zip
dev-python/rdflib: add -test.patch
fixes upstream https://github.com/RDFLib/rdflib/issues/396 Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-python/rdflib/rdflib-4.1.2.ebuild')
-rw-r--r--dev-python/rdflib/rdflib-4.1.2.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/dev-python/rdflib/rdflib-4.1.2.ebuild b/dev-python/rdflib/rdflib-4.1.2.ebuild
index ea599e27a076..72974e69a1fd 100644
--- a/dev-python/rdflib/rdflib-4.1.2.ebuild
+++ b/dev-python/rdflib/rdflib-4.1.2.ebuild
@@ -1,4 +1,3 @@
-
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -34,6 +33,8 @@ DEPEND="${RDEPEND}
test? ( dev-python/sparql-wrapper[${PYTHON_USEDEP}]
>=dev-python/nose-1.3.1-r1[${PYTHON_USEDEP}] )"
+PATCHES=( "${FILESDIR}"/${PN}-4-test.patch )
+
python_prepare_all() {
# Upstream manufactured .pyc files which promptly break distutils' src_test
find -name "*.py[oc~]" -delete || die
@@ -46,15 +47,9 @@ python_prepare_all() {
}
python_test() {
+ # the default; nose with: --where=./ does not work for python3
if python_is_python3; then
pushd "${BUILD_DIR}/src/" > /dev/null
- if [[ "${EPYTHON}" == 'python3.4' ]]; then
- sed -e 's:test_rdfpipe_bytes_vs_str:_&:' \
- -e 's:test_rdfpipe_mdata_open:_&:' \
- -i test/test_issue375.py || die
- sed -e 's:testHTML:_&:' \
- -i test/test_xmlliterals.py || die
- fi
"${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
popd > /dev/null
else