summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-24 14:15:27 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-24 16:31:29 +0200
commit55d5dbf03ec30a970bc7cb7f19448b75e66e91af (patch)
tree7c729957c87814521eb1cd403a1516c0870cc905 /dev-python/readthedocs-sphinx-ext
parentdev-python/tblib: Bump to 1.7.0 (diff)
downloadgentoo-55d5dbf03ec30a970bc7cb7f19448b75e66e91af.tar.gz
gentoo-55d5dbf03ec30a970bc7cb7f19448b75e66e91af.tar.bz2
gentoo-55d5dbf03ec30a970bc7cb7f19448b75e66e91af.zip
dev-python/readthedocs-sphinx-ext: Bump to 2.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/readthedocs-sphinx-ext')
-rw-r--r--dev-python/readthedocs-sphinx-ext/Manifest1
-rw-r--r--dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/readthedocs-sphinx-ext/Manifest b/dev-python/readthedocs-sphinx-ext/Manifest
index 2a1d379d2ab0..8ff50b8bf418 100644
--- a/dev-python/readthedocs-sphinx-ext/Manifest
+++ b/dev-python/readthedocs-sphinx-ext/Manifest
@@ -1,2 +1,3 @@
DIST readthedocs-sphinx-ext-1.0.4.tar.gz 11686 BLAKE2B 3c188e52682f8c24633f79b9ec0eed7f06c922989f7578f06e0ede0e3844ca019e1905450df8d12150d05f3a82a1103a0786cb2c60dc3551e3e3097849cdc301 SHA512 52f45c26ae934b44a41073a9e77096ea8ed97f2a36ed1ea9b63084be0af58dcff24c6b729cda7a8b631f9fe5f56822ceabdbbd2e11056b44df18212986cb445a
DIST readthedocs-sphinx-ext-2.1.0.tar.gz 9961 BLAKE2B a172fb2b7bff930f4ef728c5509e0a303bd46fd07e5da496721896751dcd0fa4fa4ba3b4d3251931598cb6172e186a3f340100f13d88c840bcb6912e5a134185 SHA512 81e60f3b6216e1c0fef12493e668cff561937bc5da965b0dfd06dca2f034f95291dfa977f94f726ec7f0bf048fa57d9fd7887219ec172b14ff2558be5e09a130
+DIST readthedocs-sphinx-ext-2.1.1.tar.gz 10181 BLAKE2B 01ca34befd0f18bb747d7f843e0cc394e19db4fe471f2bb21617b6dbdf4c1ad9721047185561f9bfbd8f770e1fefd5b560e65d7c5e2675c1bc8d74e08252eeb1 SHA512 5594e375133477ecdc1d22a78c0d4dac73c5e8c1715f4309a9674497ef860b07e8872bb4ba471fbffacd8bd22bc49741b8df54ad9ca9bb474acd9cdee72c8969
diff --git a/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.1.ebuild b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.1.ebuild
new file mode 100644
index 000000000000..e8bb844066b9
--- /dev/null
+++ b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Code specific for Read the Docs and Sphinx"
+HOMEPAGE="https://github.com/readthedocs/readthedocs-sphinx-ext"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jinja-2.9[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+PDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${PDEPEND} )"
+
+# unittest should be sufficient but tests are very verbose, so pytest's
+# output capture is most welcome
+distutils_enable_tests pytest