summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-05 19:03:14 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-05 19:03:14 +0100
commitc4667a669e878c92743fa7d11ed1733a85203fc3 (patch)
treee6286086b9df6d51335af5e4501e500cd7a75a32 /dev-python/readthedocs-sphinx-ext
parentdev-python/sphinx_rtd_theme: Revbump to drop py2 (diff)
downloadgentoo-c4667a669e878c92743fa7d11ed1733a85203fc3.tar.gz
gentoo-c4667a669e878c92743fa7d11ed1733a85203fc3.tar.bz2
gentoo-c4667a669e878c92743fa7d11ed1733a85203fc3.zip
dev-python/readthedocs-sphinx-ext: Revbump to drop py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/readthedocs-sphinx-ext')
-rw-r--r--dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-1.0.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-1.0.1-r1.ebuild b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..d3de5b22a6cd
--- /dev/null
+++ b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-1.0.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Code specific for Read the Docs and Sphinx"
+HOMEPAGE="https://github.com/readthedocs/readthedocs-sphinx-ext"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/jinja-2.9[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+PDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${PDEPEND} )"
+
+# unittest should be sufficient but tests are very verbose, so pytest's
+# output capture is most welcome
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/find_packages/s:):, exclude=["tests"]):' setup.py || die
+ distutils-r1_src_prepare
+}