summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-16 22:36:03 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-16 22:41:07 +0100
commit96d16f46d8d6e66d9d6d254b742d0e50b40c926c (patch)
treeae924ecc629cacb5870c7e83cc1cab95e2d7101b /dev-python/redis-py
parentgames-simulation/sky-rogue: Bump to 1.3.3, drop old 1.3, EAPI 8 (diff)
downloadgentoo-96d16f46d8d6e66d9d6d254b742d0e50b40c926c.tar.gz
gentoo-96d16f46d8d6e66d9d6d254b742d0e50b40c926c.tar.bz2
gentoo-96d16f46d8d6e66d9d6d254b742d0e50b40c926c.zip
dev-python/redis-py: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/redis-py')
-rw-r--r--dev-python/redis-py/Manifest2
-rw-r--r--dev-python/redis-py/redis-py-4.1.2.ebuild77
-rw-r--r--dev-python/redis-py/redis-py-4.1.3.ebuild78
3 files changed, 0 insertions, 157 deletions
diff --git a/dev-python/redis-py/Manifest b/dev-python/redis-py/Manifest
index 42c5e9bf3007..3a03302e5632 100644
--- a/dev-python/redis-py/Manifest
+++ b/dev-python/redis-py/Manifest
@@ -1,3 +1 @@
-DIST redis-py-4.1.2.tar.gz 2349862 BLAKE2B 3e68918654e63c3403f2408350b2a877027a3c3990b623818332e0e77e1fbaa413e85912ea586a90788a87e0206ebe408ab55df522864dc534907c31a690c0c1 SHA512 beb6e50051eae61e84e7cf37f9f3e3efbc404d49e506b0b3bdae0d0c45fd940f12c801434a6394505519bf327b5933c076ad4f8c66ad812441bc08b3aa682542
-DIST redis-py-4.1.3.tar.gz 2349885 BLAKE2B d1c16a88e7ec70cf2b954fa9cf841f971c02023b7c9387e3e680e16972d546347ee454febf096e54f7bfcd4dabf163e22e1a0ba3186cbb9417cdd7a613d5a992 SHA512 797c1ee4ff4f0e32b52add5bc1cc81fd36cb1eb4d6f9328b38dca46c79a01bc105bc172f56d3bea20d802ee7a6eb934c2ee3ab5f611a49d77f9c4c50d7a4b0d8
DIST redis-py-4.1.4.tar.gz 2352106 BLAKE2B a7f40d381e3e1d295d2ce88f0adb897704d0065ee7d5bb00108c2c8c67ef649ea63d4ca06dbbe2b21b2f92d70d96f8e2d32a7992ecf702bb4c73589f30c1bae8 SHA512 6dd1bc7622529382901b2fe6e63a5f9d6a4b89175b486c879a63cc8f0e708737431dfe5b834124f0d33f34540ac54813a0e6953bbed3a9dbd226597b4b1cb3ae
diff --git a/dev-python/redis-py/redis-py-4.1.2.ebuild b/dev-python/redis-py/redis-py-4.1.2.ebuild
deleted file mode 100644
index 7c10c028f214..000000000000
--- a/dev-python/redis-py/redis-py-4.1.2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-MY_PN="redis"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python client for Redis key-value store"
-HOMEPAGE="https://github.com/redis/redis-py"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 sparc x86"
-
-RDEPEND="
- dev-python/deprecated[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Flaky test
- tests/test_pubsub.py::TestPubSubDeadlock::test_pubsub_deadlock
-
- # Needs a second Redis running
- tests/test_commands.py::TestRedisCommands::test_sync
- tests/test_commands.py::TestRedisCommands::test_psync
- )
-
- local EPYTEST_IGNORE=(
- # SSL tests need Docker/stunnel:
- # https://github.com/redis/redis-py/commit/18c6809b761bc6755349e1d7e08e74e857ec2c65
- tests/test_ssl.py
-
- # Needs multiple Redises running
- tests/test_cluster.py
- )
-
- epytest -k "not redismod and not ssl"
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
-
- # Spawn Redis itself for testing purposes
- # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
- # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- # "${EPREFIX}"/usr/sbin/redis-server - <<< "${redis_test_config}" || die
- "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- EOF
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}
diff --git a/dev-python/redis-py/redis-py-4.1.3.ebuild b/dev-python/redis-py/redis-py-4.1.3.ebuild
deleted file mode 100644
index c0b0dc09baf3..000000000000
--- a/dev-python/redis-py/redis-py-4.1.3.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-MY_PN="redis"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python client for Redis key-value store"
-HOMEPAGE="https://github.com/redis/redis-py"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-
-RDEPEND="
- dev-python/deprecated[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Flaky test
- tests/test_pubsub.py::TestPubSubDeadlock::test_pubsub_deadlock
-
- # Needs a second Redis running
- tests/test_commands.py::TestRedisCommands::test_sync
- tests/test_commands.py::TestRedisCommands::test_psync
- )
-
- local EPYTEST_IGNORE=(
- # SSL tests need Docker/stunnel:
- # https://github.com/redis/redis-py/commit/18c6809b761bc6755349e1d7e08e74e857ec2c65
- tests/test_ssl.py
-
- # Needs multiple Redises running
- tests/test_cluster.py
- )
-
- epytest -k "not redismod and not ssl"
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
-
- # Spawn Redis itself for testing purposes
- # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
- # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- # "${EPREFIX}"/usr/sbin/redis-server - <<< "${redis_test_config}" || die
- "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- EOF
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}