summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-01-29 09:50:53 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-01-29 09:51:54 -0800
commitc3ed2b3c9825c2a16cf2515b079aac75a86eb9ab (patch)
tree030ff8e8155295ca08f878324fb28c908f67e985 /dev-python/reflink
parentnet-analyzer/nagios-plugins: amd64 stable wrt bug #676042 (diff)
downloadgentoo-c3ed2b3c9825c2a16cf2515b079aac75a86eb9ab.tar.gz
gentoo-c3ed2b3c9825c2a16cf2515b079aac75a86eb9ab.tar.bz2
gentoo-c3ed2b3c9825c2a16cf2515b079aac75a86eb9ab.zip
dev-python/reflink: correct dep on pytest-runner
Closes: https://bugs.gentoo.org/676848 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-python/reflink')
-rw-r--r--dev-python/reflink/files/0.2.1-correct-test-deps.patch17
-rw-r--r--dev-python/reflink/reflink-0.2.1.ebuild2
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/reflink/files/0.2.1-correct-test-deps.patch b/dev-python/reflink/files/0.2.1-correct-test-deps.patch
new file mode 100644
index 000000000000..78b1ef8fd94e
--- /dev/null
+++ b/dev-python/reflink/files/0.2.1-correct-test-deps.patch
@@ -0,0 +1,17 @@
+diff --git a/setup.py b/setup.py
+index 234c92b..3ef3237 100644
+--- a/setup.py
++++ b/setup.py
+@@ -20,11 +20,11 @@ requirements = [
+
+ setup_requirements = [
+ 'cffi',
+- 'pytest-runner',
+ ]
+
+ test_requirements = [
+ 'pytest',
++ 'pytest-runner',
+ ]
+
+ if sys.platform not in ['linux', 'linux2', 'win32', 'darwin']:
diff --git a/dev-python/reflink/reflink-0.2.1.ebuild b/dev-python/reflink/reflink-0.2.1.ebuild
index 8c8c593ccf52..59c051cb1949 100644
--- a/dev-python/reflink/reflink-0.2.1.ebuild
+++ b/dev-python/reflink/reflink-0.2.1.ebuild
@@ -30,6 +30,8 @@ DEPEND="${RDEPEND}"
# goes places, like writing to /dev or creating btrfs volumes
RESTRICT="test"
+PATCHES=( "${FILESDIR}/${PV}-correct-test-deps.patch" )
+
python_compile_all() {
use doc && emake -C docs html
}