summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/rencode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/rencode')
-rw-r--r--dev-python/rencode/Manifest1
-rw-r--r--dev-python/rencode/metadata.xml18
-rw-r--r--dev-python/rencode/rencode-1.0.3.ebuild20
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/rencode/Manifest b/dev-python/rencode/Manifest
new file mode 100644
index 000000000000..0e69ebe593fb
--- /dev/null
+++ b/dev-python/rencode/Manifest
@@ -0,0 +1 @@
+DIST rencode-1.0.3.tar.gz 24105 SHA256 13c47ca2f9cf060083de7e5886e725731863c4a5d95545c68e0bb3a2149da444 SHA512 2697c496d34e2a6a9fe0ab7bdc57e4dab97e5d7409d7530899f951a08c9f32740fd0b0da644afa7cc98c3248f5aa034717b93644d02083fd2ef5f224269fef3f WHIRLPOOL 05580374bc5419586fe88757b498fa8ae1b0591c15263ec016a2d1300252b8b28dfe8c3761904e73577b86c0059e5a195c89488f281057dcc4f9c377d2a408d1
diff --git a/dev-python/rencode/metadata.xml b/dev-python/rencode/metadata.xml
new file mode 100644
index 000000000000..4904a9fc21e8
--- /dev/null
+++ b/dev-python/rencode/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <longdescription lang="en">
+The rencode module is similar to bencode from the BitTorrent project. For
+complex, heterogeneous data structures with many small elements, r-encodings
+take up significantly less space than b-encodings. This version of rencode is
+a complete rewrite in Cython to attempt to increase the performance over the
+pure Python module written by Petru Paler, Connelly Barnes et al.
+</longdescription>
+ <upstream>
+ <remote-id type="github">aresch/rencode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rencode/rencode-1.0.3.ebuild b/dev-python/rencode/rencode-1.0.3.ebuild
new file mode 100644
index 000000000000..19d6380bfc66
--- /dev/null
+++ b/dev-python/rencode/rencode-1.0.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+inherit distutils-r1
+
+DESCRIPTION="similar to bencode from the BitTorrent project"
+HOMEPAGE="https://github.com/aresch/rencode"
+SRC_URI="https://github.com/aresch/rencode/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""