summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-05-10 11:40:12 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-05-10 11:40:49 -0500
commitdd55d639a379a5e115b7d13675f7e0e63742ca5e (patch)
tree1369353a970c82d6cc8d1f3ae4018b27d2e6dbf7 /dev-python/reno
parentdev-python/dulwich: adding arm64 support (diff)
downloadgentoo-dd55d639a379a5e115b7d13675f7e0e63742ca5e.tar.gz
gentoo-dd55d639a379a5e115b7d13675f7e0e63742ca5e.tar.bz2
gentoo-dd55d639a379a5e115b7d13675f7e0e63742ca5e.zip
dev-python/reno: 2.2.1 bup
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/reno')
-rw-r--r--dev-python/reno/Manifest1
-rw-r--r--dev-python/reno/reno-2.2.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/reno/Manifest b/dev-python/reno/Manifest
index 5a83e2805fb5..b93e879cd825 100644
--- a/dev-python/reno/Manifest
+++ b/dev-python/reno/Manifest
@@ -1,2 +1,3 @@
DIST reno-1.2.0.tar.gz 23725 SHA256 8f2c4f9b8325e6de4a5a2a98169b2906bd2479cc2c66b97cd6899da455425fd3 SHA512 61abf852504ab9ace324efc70bbe4bf5ce226175a4375f37466ebbe011cb65c7d306d69cd90a5e152f03d60f578be02d57a3805647a486e44dccf59b17595083 WHIRLPOOL 4a25f46b2a3c7693642104402db8bc024c82d19e3d8e3a11c899485aa7acd005a868a31665a0bb827f4922869c08297d63bdba5df76f0bf81cf8b95b2faa35db
DIST reno-1.8.0.tar.gz 33367 SHA256 fa8e478fe070b6f658fa4868941449cc6dca7b08f520756dcebed2c87e070fdf SHA512 b8254cddd713d85dbbbedfaca864950093a2194e3a2e9754e5fb2490b2434d808dc3ae3659e901df0cf5ce7f33d6bf07d1c39fc086526a127643636199420d64 WHIRLPOOL 3c6e288af413ddf97be057278bec4ecbdda0fd1e80b29f52b20f3ccd6212090e16842e98a50e5dbe65260cb279112d87af3ee00aeb5371bc0dbb374a378e501c
+DIST reno-2.2.1.tar.gz 56013 SHA256 2feebbeb0fa0cfd4cd19d7fba5bdd334a10a82515b1d8c3c5fc732c076c84ec7 SHA512 278a7a43168f9467342f25c3eb8692e119cac285940b5d3f5a13f8f45acaffde962d2eeac720f2e5d824d085446fe5d660ef7082f95dd3c0360d594de5a65fb1 WHIRLPOOL 30203bbb1f1f8749e43b4c5a3cfe2dd3bfbd5ecf63b9fbcd6a47e8f148d58cd02c895311557919f4e2e27fafda326162edc9df77f71fb3c258b5dc1a6e7295ce
diff --git a/dev-python/reno/reno-2.2.1.ebuild b/dev-python/reno/reno-2.2.1.ebuild
new file mode 100644
index 000000000000..2d71015bcdba
--- /dev/null
+++ b/dev-python/reno/reno-2.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Release notes manager, storing release notes in a git repo and building docs"
+HOMEPAGE="https://pypi.python.org/pypi/reno"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND="
+ >=dev-python/pbr-1.4[${PYTHON_USEDEP}]
+ <dev-python/pbr-2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.15.0[${PYTHON_USEDEP}]"