summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-22 21:47:25 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-23 01:10:53 +0100
commit5041ed07109694ea4ef8050a2e985c37f4d2be3c (patch)
treeb2712d8490158f8ab4e8c73e3d9c94013dafb355 /dev-python/reportlab
parentdev-python/serverfiles: Add python@ as co-maint and ALLARCHES (diff)
downloadgentoo-5041ed07109694ea4ef8050a2e985c37f4d2be3c.tar.gz
gentoo-5041ed07109694ea4ef8050a2e985c37f4d2be3c.tar.bz2
gentoo-5041ed07109694ea4ef8050a2e985c37f4d2be3c.zip
dev-python/reportlab: Bump to 3.5.60
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/reportlab')
-rw-r--r--dev-python/reportlab/Manifest1
-rw-r--r--dev-python/reportlab/reportlab-3.5.60.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/reportlab/Manifest b/dev-python/reportlab/Manifest
index 42118ba8b139..285b9798066c 100644
--- a/dev-python/reportlab/Manifest
+++ b/dev-python/reportlab/Manifest
@@ -3,3 +3,4 @@ DIST reportlab-3.5.56.tar.gz 2899527 BLAKE2B 83f14c472a8675449e2f50f806fc5136fce
DIST reportlab-3.5.57.tar.gz 2901465 BLAKE2B ecb0459414d359b8feb048ad34cfd782a6913f2e254f6d8832dd076fe63fda82d24c4dda28da9c0cc6765c284d51a45d44459d225899574625212c33800116dc SHA512 d325e389ddd7d3c4d98e462956a3c4b7237c9219728577a1e0599a137d19a27205b223fd13c5c260e2968c435bc06b2e4745945ac056926543a47e52868e21db
DIST reportlab-3.5.58.tar.gz 2903638 BLAKE2B ac19bda75e111266b35a939fc64ac44de4ad69dc7a7cbf9fdabc233e28f33589ba97dc5082cd38d5b8d11a2c7aaab0bac69a1453d8661fd26017f8e07299c2e8 SHA512 949b50f65ca305f79fbb06e7e7b1ebfb6546864892f764a3440eaed0a95ac001a71d3685e8702032573ed60893b9529bd2356b1d5419882058a3b9aab986cb64
DIST reportlab-3.5.59.tar.gz 2904089 BLAKE2B ab9bdbc8decda8f858c49a7ffe5ed919a2ca971a20967be45bdb780d9480aa474462c76f886756b433cee3ccd4d78e245334dc6a600c8e19c28ad79befe14705 SHA512 c862acb10f4eaed877321afadb52615132dcda0976e648e1767c32cd0398fc2763048f274d31da6088cb824311e8a28fee048cd6e98411e70583cfb36d0050ca
+DIST reportlab-3.5.60.tar.gz 2905122 BLAKE2B 8863e910dac03d5fd1d53880bb9fe83d218641156e481c97b498e462cf9e1e5c6826f2f25fcef7c65cee3dbc7551401bfd1dba6a319532363b7c9cbc9c37e618 SHA512 395ad0c904215ba3ae16efa52140b7cc6f751efd04c70f687a8891806b346d78c75bb29df5aa0d6d49adb6f5638da58704e713ee1500df05424c9dddc38afad2
diff --git a/dev-python/reportlab/reportlab-3.5.60.ebuild b/dev-python/reportlab/reportlab-3.5.60.ebuild
new file mode 100644
index 000000000000..715b36b555d2
--- /dev/null
+++ b/dev-python/reportlab/reportlab-3.5.60.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Tools for generating printable PDF documents from any data source"
+HOMEPAGE="
+ https://www.reportlab.com/
+ https://pypi.org/project/reportlab/"
+SRC_URI="
+ mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz
+ https://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ media-libs/freetype
+ media-libs/libart_lgpl
+ sys-libs/zlib:="
+RDEPEND="
+ ${DEPEND}
+ dev-python/pillow[tiff,truetype,jpeg(+),${PYTHON_USEDEP}]"
+BDEPEND="
+ app-arch/unzip
+ test? ( ${RDEPEND} )"
+
+distutils_enable_sphinx docs/source
+
+PATCHES=(
+ # bug 738312, remove -L/usr/lib from link line
+ "${FILESDIR}"/${PN}-3.5.48-usr-lib-LLD.patch
+)
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${P}/src/reportlab/fonts || die
+ unpack pfbfer-20070710.zip
+}
+
+python_prepare_all() {
+ # tests requiring Internet access
+ sed -i -e 's:test0:_&:' \
+ tests/test_platypus_general.py \
+ tests/test_platypus_images.py || die
+ sed -i -e 's:test9:_&:' tests/test_lib_utils.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pushd tests >/dev/null || die
+ "${EPYTHON}" runAll.py || die "Testing failed with ${EPYTHON}"
+ popd >/dev/null || die
+}