summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-03 18:14:09 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-03 18:30:46 +0100
commitd8a9eba0119c54f5c2117e67824415e909a731d6 (patch)
tree1abcdf593a53a77e275638806e79033e4481fb39 /dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild
parentdev-python/repoze-lru: Remove namespace dep (diff)
downloadgentoo-d8a9eba0119c54f5c2117e67824415e909a731d6.tar.gz
gentoo-d8a9eba0119c54f5c2117e67824415e909a731d6.tar.bz2
gentoo-d8a9eba0119c54f5c2117e67824415e909a731d6.zip
dev-python/repoze-sphinx-autointerface: Remove namespace dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild')
-rw-r--r--dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild b/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild
deleted file mode 100644
index 02e4c048c909..000000000000
--- a/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-MY_PN=${PN//-/.}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Sphinx extension: auto-generates API docs from Zope interfaces"
-HOMEPAGE="https://pypi.org/project/repoze.sphinx.autointerface/"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="repoze"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-RDEPEND="
- dev-python/namespace-repoze[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
-"
-
-S=${WORKDIR}/${MY_P}
-
-python_install() {
- distutils-r1_python_install
-
- # install the namespace (it's the only subpackage)
- python_moduleinto repoze.sphinx
- python_domodule repoze/sphinx/__init__.py
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- find "${D}" -name '*.pth' -delete || die
-}