summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-22 08:53:00 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-22 09:25:22 +0200
commit15784871097863e8230f0634f575a03ad7164f23 (patch)
treeb2e79fbf34f97ea6f0d8a4b92a32fb750a36666a /dev-python/requests-cache
parentapp-admin/awscli: Bump to 1.20.4 (diff)
downloadgentoo-15784871097863e8230f0634f575a03ad7164f23.tar.gz
gentoo-15784871097863e8230f0634f575a03ad7164f23.tar.bz2
gentoo-15784871097863e8230f0634f575a03ad7164f23.zip
dev-python/requests-cache: Bump to 0.7.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/requests-cache')
-rw-r--r--dev-python/requests-cache/Manifest1
-rw-r--r--dev-python/requests-cache/requests-cache-0.7.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/requests-cache/Manifest b/dev-python/requests-cache/Manifest
index 7263f500970a..2a19afcb44fe 100644
--- a/dev-python/requests-cache/Manifest
+++ b/dev-python/requests-cache/Manifest
@@ -1,2 +1,3 @@
DIST requests-cache-0.6.4.gh.tar.gz 50322 BLAKE2B c9a6cae957604bdfa6057621e028fad83476e5d918bbf9c58e73f09f8615398946f3cf6e3737c9ff916cba68d82ed66a674557fb733c74b874b0f68e2430d9a0 SHA512 31e2217e54892d8ec5fc9fcf60f650960621b1f97029c90deca925b9a1be9eb5a3ddb6ae68e581c805f20136f93eefa70d51e7e9f086ecbae76f8e550bbe3f1a
DIST requests-cache-0.7.1.gh.tar.gz 959455 BLAKE2B ce41514f21dc0708e437f70b92eb9d84f47433d04a11476cd5afefd050089e2d138213fa0b2f6bac200bd6d59db996187481ef3544d289a5117f3fe7160027b5 SHA512 cd83134ce9500c20c63fa92546cca41772ba3582a669914cd0885ec5aadf6ae4a6c4fc6a83dce73d2d5b24a80db2fde65cdb0a89b4b5703ddeac1d710404a05d
+DIST requests-cache-0.7.2.gh.tar.gz 962215 BLAKE2B 0f66548b4c37c14347021a4675d0165b9f9648dc9842f1d94c9507c096f6ef359f7109f88ac369de2de263673542f42d6e4a7402449354aee900970331f87cea SHA512 1712f3568ec4c8c41988c9d2ca07e72b1a66efceb596d814219b5eb9bb0c05448ee33b4634ec39fb03634032a6bfaaf877b297be7f92f540788dba40b4c202df
diff --git a/dev-python/requests-cache/requests-cache-0.7.2.ebuild b/dev-python/requests-cache/requests-cache-0.7.2.ebuild
new file mode 100644
index 000000000000..32b48e1d7368
--- /dev/null
+++ b/dev-python/requests-cache/requests-cache-0.7.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+HOMEPAGE="
+ https://pypi.org/project/requests-cache/
+ https://github.com/reclosedev/requests-cache/"
+DESCRIPTION="Persistent cache for requests library"
+SRC_URI="
+ https://github.com/reclosedev/requests-cache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/cattrs[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/url-normalize-1.4[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/timeout-decorator[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local skipped_tests=(
+ # These require extra servers running
+ tests/integration/test_dynamodb.py
+ tests/integration/test_gridfs.py
+ tests/integration/test_mongodb.py
+ tests/integration/test_redis.py
+ # Requires Internet access
+ tests/integration/test_compat.py::test_version_upgrade
+ )
+
+ local -x USE_PYTEST_HTTPBIN=true
+ epytest ${skipped_tests[@]/#/--deselect }
+}