summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-05-31 17:18:28 +0200
committerSam James <sam@gentoo.org>2023-05-31 17:49:20 +0100
commit51181833149276a948592c0b35bfeea36c777121 (patch)
tree2382b1887f6ff4dfbda12554e029cb57864930b7 /dev-python/requests-futures
parentdev-python/requests-unixsocket: enable py3.12 (diff)
downloadgentoo-51181833149276a948592c0b35bfeea36c777121.tar.gz
gentoo-51181833149276a948592c0b35bfeea36c777121.tar.bz2
gentoo-51181833149276a948592c0b35bfeea36c777121.zip
dev-python/requests-futures: enable py3.12
Tested multiple times with ALLOW_TEST=network, some test runs passed, few did not with error: AssertionError: 200 != 504. Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/requests-futures')
-rw-r--r--dev-python/requests-futures/requests-futures-1.0.0-r1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-python/requests-futures/requests-futures-1.0.0-r1.ebuild b/dev-python/requests-futures/requests-futures-1.0.0-r1.ebuild
index b83e39964223..906db679d689 100644
--- a/dev-python/requests-futures/requests-futures-1.0.0-r1.ebuild
+++ b/dev-python/requests-futures/requests-futures-1.0.0-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1 pypi