summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-03 19:43:32 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-03 19:49:08 +0200
commit4d0e2aad5aacbc1900078ba4d7e1a04506f5a828 (patch)
tree107e3554c49875d1ce69da1f755bd5b67bfc936e /dev-python/requests
parentdev-python/sphinx-jinja: add 1.4.0 (diff)
downloadgentoo-4d0e2aad5aacbc1900078ba4d7e1a04506f5a828.tar.gz
gentoo-4d0e2aad5aacbc1900078ba4d7e1a04506f5a828.tar.bz2
gentoo-4d0e2aad5aacbc1900078ba4d7e1a04506f5a828.zip
dev-python/requests: add 2.27.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/requests')
-rw-r--r--dev-python/requests/Manifest1
-rw-r--r--dev-python/requests/requests-2.27.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/requests/Manifest b/dev-python/requests/Manifest
index ccbcf2aecad2..86239771fdbe 100644
--- a/dev-python/requests/Manifest
+++ b/dev-python/requests/Manifest
@@ -1 +1,2 @@
DIST requests-2.26.0.tar.gz 104433 BLAKE2B 49872a0602ab0e6b3838c4ff84d6611c5265dd584a1902b51d5903a2fc566b97f7a70973a9244adf190e9249bc6d1fa448a2164a31d125ab6b3dac172ae62e1c SHA512 c3397d77f0d2f1afb05661c4b98adad6c1ddaf360906254150b33ab0d9479fd306905bd6d61b8cf8becd9a40bdcf9b03542e8267c644ef19f03f44bfca0bc461
+DIST requests-2.27.0.tar.gz 108487 BLAKE2B a24e9071d39b8677309c5a847910cfb8bf91b22b522bebc8166e9fb3a36ce9783bb23ad725d43aa19da5cf3a1b11bfc21766a2995ba9810b6c973b03a7acdd1b SHA512 9d43c637bebb1b98fc25f895308673153686ef0b97e5d568526fb63c348dc939fab620fd7c550fef0a2977e98a466c8dae0710cef5b969b28b9a4f3a1f9940f5
diff --git a/dev-python/requests/requests-2.27.0.ebuild b/dev-python/requests/requests-2.27.0.ebuild
new file mode 100644
index 000000000000..eac11c53b979
--- /dev/null
+++ b/dev-python/requests/requests-2.27.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library for human beings"
+HOMEPAGE="https://requests.readthedocs.io/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="socks5"
+
+RDEPEND="
+ >=dev-python/certifi-2017.4.17[${PYTHON_USEDEP}]
+ dev-python/charset_normalizer[${PYTHON_USEDEP}]
+ <dev-python/idna-4[${PYTHON_USEDEP}]
+ <dev-python/urllib3-1.27[${PYTHON_USEDEP}]
+ socks5? ( >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}] )
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
+ !alpha? ( !hppa? ( !ia64? (
+ dev-python/trustme[${PYTHON_USEDEP}]
+ ) ) )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet (doctests)
+ requests/__init__.py::requests
+ requests/api.py::requests.api.request
+ requests/models.py::requests.models.PreparedRequest
+ requests/sessions.py::requests.sessions.Session
+ # require IPv4 interface in 10.* range
+ tests/test_requests.py::TestTimeout::test_connect_timeout
+ tests/test_requests.py::TestTimeout::test_total_timeout_connect
+ # TODO: openssl?
+ tests/test_requests.py::TestRequests::test_pyopenssl_redirect
+ )
+
+ if ! has_version "dev-python/trustme[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_requests.py::TestRequests::test_https_warnings
+ )
+ fi
+
+ epytest
+}