summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2018-12-13 23:39:57 -0800
committerPatrick McLean <chutzpah@gentoo.org>2018-12-13 23:39:57 -0800
commiteabe7b1f4a0f9f9605c22b5cb39799485dd7e652 (patch)
treec16d46004ec44aee2b6f5e0682064acd0c93e839 /dev-python/requests
parentdev-python/urllib3: Version bump to 1.24.1 (diff)
downloadgentoo-eabe7b1f4a0f9f9605c22b5cb39799485dd7e652.tar.gz
gentoo-eabe7b1f4a0f9f9605c22b5cb39799485dd7e652.tar.bz2
gentoo-eabe7b1f4a0f9f9605c22b5cb39799485dd7e652.zip
dev-python/requests: Version bump to 2.21.0
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/requests')
-rw-r--r--dev-python/requests/Manifest1
-rw-r--r--dev-python/requests/requests-2.21.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/requests/Manifest b/dev-python/requests/Manifest
index 82ec89a1020f..96e5ad527dd4 100644
--- a/dev-python/requests/Manifest
+++ b/dev-python/requests/Manifest
@@ -4,3 +4,4 @@ DIST requests-2.14.2.tar.gz 521027 BLAKE2B c8f691b126876e069556542dbfc86a6aa6452
DIST requests-2.18.2.tar.gz 125381 BLAKE2B f55bee7558424662ff5d577eefc89cdbdec3a209667bd174a3ec73554bab20582867139ce69ed5b996ecfb297cc251d41294188e21bd24d2241a0ad0432582f2 SHA512 b78660e5370f9acc458159edda385fbcbbb33b0703fa2c83400f3c08fe05253f357175e2ad76c5bff4bd942ab18da5df344473e9b5a924d7457596c0ff9bfbc6
DIST requests-2.18.4.tar.gz 126224 BLAKE2B 98ab1fe39832673ea7900029da275e031fc85811d6ddb0f37609ec50b18e17d8a04b6cef397bc626ba13da32e16ffa961626879106941d327694d8763dc1efb6 SHA512 5c59bed82ac1094194f04a973b299f7d783264d372abd7a5229295bccc6b2f7a9f082ee4b0dff348e9c22cf68ddbd7cb67f60fd0b7d9eda41c02e40d075e9472
DIST requests-2.19.1.tar.gz 131068 BLAKE2B 54ffdfd7b2c6f504071c8b55d9672dcffafd31de90cb85d354bc17d7fa19807927b46977b22a407654cdb48d7293e1b0222771d4369e148e4d6410719ba820e3 SHA512 deef2662227497b472f6e7eb7f0ee468c772069fc66552f71d80e5a12af62a187f8bc6a8a78531915e824c7f277d0db61c1534c89d13d473f68504f0bd6edf47
+DIST requests-2.21.0.tar.gz 111528 BLAKE2B 7b40f9f572a8efde41c177fb5d1e1eaf29ca60cad0661fa28ac0085f3700348380d619f68c0082f24044d1af82b16d6b1e7d5dd2c2a2329f85fcee7141b1fbf6 SHA512 385e1d80993a21c09e7c4682500ca8c24155962ba41ecd8e73612722b2ff6618b736e827fc48ad1683b0d2bc7a420cfe680f5107860aca52656ef777f1d60104
diff --git a/dev-python/requests/requests-2.21.0.ebuild b/dev-python/requests/requests-2.21.0.ebuild
new file mode 100644
index 000000000000..f549df025d93
--- /dev/null
+++ b/dev-python/requests/requests-2.21.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library for human beings"
+HOMEPAGE="http://python-requests.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="socks5 +ssl"
+
+RDEPEND="
+ >=dev-python/certifi-2017.4.17[${PYTHON_USEDEP}]
+ >=dev-python/chardet-3.0.2[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ <dev-python/idna-2.8[${PYTHON_USEDEP}]
+ <dev-python/urllib3-1.24[${PYTHON_USEDEP}]
+ socks5? ( >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}] )
+ ssl? (
+ >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.14[$(python_gen_usedep 'python*' pypy)]
+ )
+"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# tests connect to various remote sites
+RESTRICT="test"
+
+#DEPEND+="
+# test? (
+# dev-python/pytest[${PYTHON_USEDEP}]
+# dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+# dev-python/pytest-mock[${PYTHON_USEDEP}]
+# dev-python/pytest-xdist[${PYTHON_USEDEP}]
+# >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
+# )
+#"
+
+python_test() {
+ py.test || die
+}