summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-17 08:22:11 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-17 08:47:52 +0100
commitc9fdc860f5043661648c35d55ae50339ccae27da (patch)
tree4b897a66fb981f4dc56af1ed86d95175b2203aba /dev-python/responses
parentdev-python/twine: Bump to 3.4.1 (diff)
downloadgentoo-c9fdc860f5043661648c35d55ae50339ccae27da.tar.gz
gentoo-c9fdc860f5043661648c35d55ae50339ccae27da.tar.bz2
gentoo-c9fdc860f5043661648c35d55ae50339ccae27da.zip
dev-python/responses: Bump to 0.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/responses')
-rw-r--r--dev-python/responses/Manifest1
-rw-r--r--dev-python/responses/responses-0.13.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/responses/Manifest b/dev-python/responses/Manifest
index 259ec90dd8d5..bf1f6abd285d 100644
--- a/dev-python/responses/Manifest
+++ b/dev-python/responses/Manifest
@@ -1 +1,2 @@
DIST responses-0.12.1.tar.gz 27123 BLAKE2B 2c77e3ac48e7430e2c91321a946c09746953b3aa2a93aff1ad277f849bc57fe8033d405cd0c391111ba31e523ecb2dfa5bc475519fb1224dff5247925eb54616 SHA512 cc840920895c5ab02b546d6441636197e93c4dc7346a801a14d663a30a761d78a0be73e820cdd5963e52d882958d9ea7873df6fcd6c032d99a230109b5c0ddb8
+DIST responses-0.13.0.tar.gz 30265 BLAKE2B fdf111b143fb47cb9d175a3718dabe1d23199e02719ece741a6416d25dc8ecf5fc67243c9f8d982b758524db45145d494131aa3f3659f04ff60c147da0fd9947 SHA512 84a542a4d1faccb3d530357db6e1edcf666c82a2eb3bfd86a5478fa96878bd42f82ffdec358f68e954838f5dd7dfa4aa6acf3dad7e0d1881fb8816a422b0e755
diff --git a/dev-python/responses/responses-0.13.0.ebuild b/dev-python/responses/responses-0.13.0.ebuild
new file mode 100644
index 000000000000..d3c967c158e0
--- /dev/null
+++ b/dev-python/responses/responses-0.13.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Utility for mocking out the Python Requests library"
+HOMEPAGE="https://github.com/getsentry/responses"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/requests-2.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.10[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest