summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-02-24 02:14:24 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-02-24 04:21:02 +0100
commitb4570442bc89a0cb5dc5339b12b54fc6bdfec0d6 (patch)
tree1d9e2376d549601e58b9924c2f43b41d9ef4faf9 /dev-python/restructuredtext-lint
parentdev-python/hypothesis: Bump to v3.45.3 (diff)
downloadgentoo-b4570442bc89a0cb5dc5339b12b54fc6bdfec0d6.tar.gz
gentoo-b4570442bc89a0cb5dc5339b12b54fc6bdfec0d6.tar.bz2
gentoo-b4570442bc89a0cb5dc5339b12b54fc6bdfec0d6.zip
dev-python/restructuredtext-lint: Bump to v1.1.2
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/restructuredtext-lint')
-rw-r--r--dev-python/restructuredtext-lint/Manifest1
-rw-r--r--dev-python/restructuredtext-lint/restructuredtext-lint-1.1.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/restructuredtext-lint/Manifest b/dev-python/restructuredtext-lint/Manifest
index 31c62309c339..6498f057ca1d 100644
--- a/dev-python/restructuredtext-lint/Manifest
+++ b/dev-python/restructuredtext-lint/Manifest
@@ -1 +1,2 @@
DIST restructuredtext_lint-0.12.2.tar.gz 19141 BLAKE2B 69e0cf57540d5ccce8572a8c619506e3b76fd08e88019bb66c7a18a3ca2c2b91e72797c70428156e570143d6352d529088c324b18e2a08b67a8acddda7378352 SHA512 2634d740d30cafd446e3b5d3ad22e6942ec8e15d20440abe9c31ecfebebc7d1f50cc41492863ff1e6b01a8a3ad7139aa10e94022094dc7c314709e6f72176870
+DIST restructuredtext_lint-1.1.2.tar.gz 25061 BLAKE2B 5be51fb40ac3eb0ba58c053d5b54d79e0d1c0687786a877cc37d2e617dec788782e3d4aade62828a267c139b7e311405552cb61eefdbaed458c2c1206245a422 SHA512 f44eff61df3581ba345fb953a09d9bf6977003e05078bacbeea27287b0b14a6f16298db0bde5be4ebfd0843eac33de623db1e47ce6475b30dce47cdd3e9ea5d7
diff --git a/dev-python/restructuredtext-lint/restructuredtext-lint-1.1.2.ebuild b/dev-python/restructuredtext-lint/restructuredtext-lint-1.1.2.ebuild
new file mode 100644
index 000000000000..dcc36614fba1
--- /dev/null
+++ b/dev-python/restructuredtext-lint/restructuredtext-lint-1.1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Created out of frustration, it sucks to find out your reST is invalid after uploading it."
+HOMEPAGE="https://pypi.python.org/pypi/restructuredtext_lint"
+
+MY_P="restructuredtext_lint"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_P}/${MY_P}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_P}-${PV}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/docutils-0.11[${PYTHON_USEDEP}]
+ <dev-python/docutils-1.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -v || die
+}