summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-12-02 19:20:38 +0000
committerJustin Lecher <jlec@gentoo.org>2017-12-02 20:09:06 +0000
commit3f005965f7e2d80e3d46b0816572162bc72d1ebc (patch)
treed60951359c9f530eac97735bc5a07fa8ee2edcb2 /dev-python/resumable-urlretrieve/resumable-urlretrieve-0.1.5.ebuild
parentdev-python/ujson: depend on pytz for tests (diff)
downloadgentoo-3f005965f7e2d80e3d46b0816572162bc72d1ebc.tar.gz
gentoo-3f005965f7e2d80e3d46b0816572162bc72d1ebc.tar.bz2
gentoo-3f005965f7e2d80e3d46b0816572162bc72d1ebc.zip
dev-python/resumable-urlretrieve: New package
Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-python/resumable-urlretrieve/resumable-urlretrieve-0.1.5.ebuild')
-rw-r--r--dev-python/resumable-urlretrieve/resumable-urlretrieve-0.1.5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/resumable-urlretrieve/resumable-urlretrieve-0.1.5.ebuild b/dev-python/resumable-urlretrieve/resumable-urlretrieve-0.1.5.ebuild
new file mode 100644
index 000000000000..b62bd2f2ab4c
--- /dev/null
+++ b/dev-python/resumable-urlretrieve/resumable-urlretrieve-0.1.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Small library to fetch files over HTTP and resuming their download"
+HOMEPAGE="
+ https://github.com/berdario/resumable-urlretrieve
+ https://pypi.python.org/pypi/resumable-urlretrieve"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"