summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-13 16:17:12 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-13 16:17:12 +0200
commit09721f2b31c77aed06ff96da4c1a6b32a1ea00df (patch)
tree3e1b2b98ae9256f9bbc2acc0fa16981a7d7681b2 /dev-python/rfc3987
parentdev-lang/php: Stable for PPC64 (bug #581834). (diff)
downloadgentoo-09721f2b31c77aed06ff96da4c1a6b32a1ea00df.tar.gz
gentoo-09721f2b31c77aed06ff96da4c1a6b32a1ea00df.tar.bz2
gentoo-09721f2b31c77aed06ff96da4c1a6b32a1ea00df.zip
dev-python/rfc3987: initial import; ebuild by me
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/rfc3987')
-rw-r--r--dev-python/rfc3987/Manifest1
-rw-r--r--dev-python/rfc3987/metadata.xml16
-rw-r--r--dev-python/rfc3987/rfc3987-1.3.5.ebuild27
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/rfc3987/Manifest b/dev-python/rfc3987/Manifest
new file mode 100644
index 000000000000..de435ba8f015
--- /dev/null
+++ b/dev-python/rfc3987/Manifest
@@ -0,0 +1 @@
+DIST rfc3987-1.3.5.tar.gz 8509 SHA256 ed37b839553370971a1d5cd53392206206c56ea550d435ef45e6d94e7df50697 SHA512 66d74daa1653e9dfa0d8968229baa865935a8bf633504171ba9b208fddc936402184bce20828cbe90fec787a941faad0224675cd1db555cf614bfe83dca6b3f7 WHIRLPOOL 4a2b93e0c0437c835be38814ed1d8672530e19dc099bd0f0a340ba87ca55d2632239eb63cfc72586538ec813f37e79d13cae740a3a812110152833a9197b0db5
diff --git a/dev-python/rfc3987/metadata.xml b/dev-python/rfc3987/metadata.xml
new file mode 100644
index 000000000000..1f3c7f977ac9
--- /dev/null
+++ b/dev-python/rfc3987/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ <description>Python team can take the package if they wish.</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">rfc3987</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rfc3987/rfc3987-1.3.5.ebuild b/dev-python/rfc3987/rfc3987-1.3.5.ebuild
new file mode 100644
index 000000000000..894306e4beea
--- /dev/null
+++ b/dev-python/rfc3987/rfc3987-1.3.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)"
+HOMEPAGE="https://github.com/dgerber/rfc3987 http://pypi.python.org/pypi/rfc3987"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/regex[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ ${EPYTHON} -m doctest -v "${S}/${PN}.py" || die
+}