summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2015-10-08 12:21:06 +0900
committerBenda Xu <heroxbd@gentoo.org>2015-10-08 16:49:53 +0900
commit4cfe7ba0b8373f99f9d503e93f0a483c01765c9b (patch)
treeeaeb15ba7c1df16dbe30cf74b81980324251f1e1 /dev-python/root_numpy/root_numpy-4.4.0.ebuild
parentclean old (diff)
downloadgentoo-4cfe7ba0b8373f99f9d503e93f0a483c01765c9b.tar.gz
gentoo-4cfe7ba0b8373f99f9d503e93f0a483c01765c9b.tar.bz2
gentoo-4cfe7ba0b8373f99f9d503e93f0a483c01765c9b.zip
dev-python/root_numpy: version bump to 4.4.0.
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-python/root_numpy/root_numpy-4.4.0.ebuild')
-rw-r--r--dev-python/root_numpy/root_numpy-4.4.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/root_numpy/root_numpy-4.4.0.ebuild b/dev-python/root_numpy/root_numpy-4.4.0.ebuild
new file mode 100644
index 000000000000..a2a71eee707e
--- /dev/null
+++ b/dev-python/root_numpy/root_numpy-4.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Interface between ROOT and numpy"
+HOMEPAGE="https://github.com/rootpy/root_numpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-physics/root[python,${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( tutorial/. )
+ distutils-r1_python_install_all
+}