summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2015-10-12 13:43:40 +0900
committerBenda Xu <heroxbd@gentoo.org>2015-10-12 13:43:40 +0900
commitd1460f97f0068dfbaeaad3584b7de22b12509840 (patch)
treecad5af47426aac33ce16463db36ad533f6966c3b /dev-python/rootpy/rootpy-0.8.0.ebuild
parentnet-misc/putty: Old. (diff)
downloadgentoo-d1460f97f0068dfbaeaad3584b7de22b12509840.tar.gz
gentoo-d1460f97f0068dfbaeaad3584b7de22b12509840.tar.bz2
gentoo-d1460f97f0068dfbaeaad3584b7de22b12509840.zip
dev-python/rootpy: version bump to 0.8.0.
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-python/rootpy/rootpy-0.8.0.ebuild')
-rw-r--r--dev-python/rootpy/rootpy-0.8.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/rootpy/rootpy-0.8.0.ebuild b/dev-python/rootpy/rootpy-0.8.0.ebuild
new file mode 100644
index 000000000000..e221456ea09d
--- /dev/null
+++ b/dev-python/rootpy/rootpy-0.8.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="readline"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic layer on top of the ROOT framework's PyROOT bindings"
+HOMEPAGE="http://rootpy.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="
+ sci-physics/root[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytables[${PYTHON_USEDEP}]
+ dev-python/root_numpy[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]"
+
+DEPEND="
+ sci-physics/root[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# TOFIX: tests go in an infinite loop error
+RESTRICT=test
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}