summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-01-26 19:56:04 +0100
committerMatt Turner <mattst88@gentoo.org>2020-02-15 12:37:59 -0800
commitb46fe67bf81cf62b0876ad7b4073a6d8c4007010 (patch)
tree7837f91e44d21454ebf143e7a0be7fb74d1da625 /dev-python/rope/rope-0.16.0.ebuild
parentdev-python/python-jsonrpc-server: Version bump 0.3.4 (diff)
downloadgentoo-b46fe67bf81cf62b0876ad7b4073a6d8c4007010.tar.gz
gentoo-b46fe67bf81cf62b0876ad7b4073a6d8c4007010.tar.bz2
gentoo-b46fe67bf81cf62b0876ad7b4073a6d8c4007010.zip
dev-python/rope: Version bump 0.16.0 and add py3_7
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/rope/rope-0.16.0.ebuild')
-rw-r--r--dev-python/rope/rope-0.16.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/rope/rope-0.16.0.ebuild b/dev-python/rope/rope-0.16.0.ebuild
new file mode 100644
index 000000000000..a60999bb3c8d
--- /dev/null
+++ b/dev-python/rope/rope-0.16.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="https://github.com/python-rope/rope"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc"
+
+# Dependency for docbuild documentation which is not noted in
+# setup.py, using standard docutils builds docs successfully.
+DEPEND="doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib:." ${EPYTHON} ropetest/__init__.py
+}
+
+python_compile_all() {
+ if use doc; then
+ pushd docs > /dev/null || die
+ mkdir build || die
+ local i
+ for i in ./*.rst; do
+ rst2html.py $i > ./build/${i/rst/html} || die
+ done
+ popd > /dev/null || die
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/. )
+ distutils-r1_python_install_all
+}