summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-07-01 20:57:06 +0200
committerMatt Turner <mattst88@gentoo.org>2020-07-16 21:13:52 -0700
commitf8cf46d2352ce9fff6427f6ce806af7e615bab07 (patch)
treed913dca64826b7eaee59699f37e0bcbdacd11121 /dev-python/rope
parentdev-python/sphinxcontrib-issuetracker: add py3_7,8,9 (diff)
downloadgentoo-f8cf46d2352ce9fff6427f6ce806af7e615bab07.tar.gz
gentoo-f8cf46d2352ce9fff6427f6ce806af7e615bab07.tar.bz2
gentoo-f8cf46d2352ce9fff6427f6ce806af7e615bab07.zip
dev-python/rope: vers bump, add py3_8 rem py3_6
tests fail with py3_9 :( Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/Manifest1
-rw-r--r--dev-python/rope/rope-0.17.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index fda0302a1dd6..07462bd09e82 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1 +1,2 @@
DIST rope-0.16.0.tar.gz 243304 BLAKE2B 2c41572687ef245eb20abfccebcc9f12ecaa177be313cec59c85be5102b7358566570730a7140f952b0a1c515b479c3d21740d32d4678e65c4c572acf86f4e27 SHA512 33ba57b246337e413126309a521c54e861899b03fd250e148b97d9789cddf6eceab36609ea6e36e84ad1ac514bc3363f4937b01bcb96b6103c2a33bec1d4fb75
+DIST rope-0.17.0.tar.gz 248629 BLAKE2B 7c9276b5f400dfa9661f81d365eac150a124620824d400131d5da7361475e5a2d548c8b53a88e61e7ae6e483a47c8ca4b8ca773235e209e8c6fb47b0088327fd SHA512 c27a17fdf73ed0ae85fe417132acd999452ae88a7b779d84fdf73134094fd34510ae08017dc24ddd7c34cb70353b5a43021229b88819002371790e7717b8ae46
diff --git a/dev-python/rope/rope-0.17.0.ebuild b/dev-python/rope/rope-0.17.0.ebuild
new file mode 100644
index 000000000000..c5d96a7c3916
--- /dev/null
+++ b/dev-python/rope/rope-0.17.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="https://github.com/python-rope/rope"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc"
+
+# Dependency for docbuild documentation which is not noted in
+# setup.py, using standard docutils builds docs successfully.
+DEPEND="doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_compile_all() {
+ if use doc; then
+ pushd docs > /dev/null || die
+ mkdir build || die
+ local i
+ for i in ./*.rst; do
+ rst2html.py $i > ./build/${i/rst/html} || die
+ done
+ popd > /dev/null || die
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/. )
+ distutils-r1_python_install_all
+}