summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-09-13 21:58:20 -0400
committerTim Harder <radhermit@gentoo.org>2017-09-13 22:00:15 -0400
commit48a2ba2b2b093ccc43c75d6907203fa97650c89e (patch)
tree10fa91f72479b332601f4275c67d3f9d415cc7d1 /dev-python/ropemode/ropemode-0.4.ebuild
parentdev-python/rope: version bump to 0.10.7 (diff)
downloadgentoo-48a2ba2b2b093ccc43c75d6907203fa97650c89e.tar.gz
gentoo-48a2ba2b2b093ccc43c75d6907203fa97650c89e.tar.bz2
gentoo-48a2ba2b2b093ccc43c75d6907203fa97650c89e.zip
dev-python/ropemode: version bump to 0.4
Diffstat (limited to 'dev-python/ropemode/ropemode-0.4.ebuild')
-rw-r--r--dev-python/ropemode/ropemode-0.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/ropemode/ropemode-0.4.ebuild b/dev-python/ropemode/ropemode-0.4.ebuild
new file mode 100644
index 000000000000..33e4385c3ad3
--- /dev/null
+++ b/dev-python/ropemode/ropemode-0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A helper for using rope refactoring library in IDEs"
+HOMEPAGE="https://github.com/python-rope/ropemode https://pypi.python.org/pypi/ropemode"
+SRC_URI="https://github.com/python-rope/ropemode/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# pypi releases don't include tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/rope-0.9.4[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" ropemodetest.py || die "tests failed with ${EPYTHON}"
+}