summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-17 15:01:51 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-17 15:07:58 +0200
commitbcbf8c229c3577e48f86e29f664367a90093b2e2 (patch)
treeb90d37ef78990916a926197d1a6e435249c1b16e /dev-python/rosdistro/rosdistro-0.6.9.ebuild
parentdev-python/rosdistro: Remove old (diff)
downloadgentoo-bcbf8c229c3577e48f86e29f664367a90093b2e2.tar.gz
gentoo-bcbf8c229c3577e48f86e29f664367a90093b2e2.tar.bz2
gentoo-bcbf8c229c3577e48f86e29f664367a90093b2e2.zip
dev-python/rosdistro: eapi update and bump to 0.6.9
Package-Manager: Portage-2.3.46, Repoman-2.3.10
Diffstat (limited to 'dev-python/rosdistro/rosdistro-0.6.9.ebuild')
-rw-r--r--dev-python/rosdistro/rosdistro-0.6.9.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/rosdistro/rosdistro-0.6.9.ebuild b/dev-python/rosdistro/rosdistro-0.6.9.ebuild
new file mode 100644
index 000000000000..c8c67d166d09
--- /dev/null
+++ b/dev-python/rosdistro/rosdistro-0.6.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdistro"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Tools to work with catkinized rosdistro files"
+HOMEPAGE="http://wiki.ros.org/rosdistro"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ros-infrastructure/rosdistro/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --with-xunit test || die
+}