summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-01 12:37:29 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-01 12:39:01 +0200
commitabbd10a06499348e18feee42c5b42a9b975d9195 (patch)
tree8d955ecdc51d88d85393f99d5ec89cdf522f63ff /dev-python/rospkg/rospkg-1.0.40.ebuild
parentros-meta/audio_common: Bump to 0.3.1. (diff)
downloadgentoo-abbd10a06499348e18feee42c5b42a9b975d9195.tar.gz
gentoo-abbd10a06499348e18feee42c5b42a9b975d9195.tar.bz2
gentoo-abbd10a06499348e18feee42c5b42a9b975d9195.zip
dev-python/rospkg: bump to 1.0.40
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/rospkg/rospkg-1.0.40.ebuild')
-rw-r--r--dev-python/rospkg/rospkg-1.0.40.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/rospkg/rospkg-1.0.40.ebuild b/dev-python/rospkg/rospkg-1.0.40.ebuild
new file mode 100644
index 000000000000..9939d92441ae
--- /dev/null
+++ b/dev-python/rospkg/rospkg-1.0.40.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rospkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the ROS package system"
+HOMEPAGE="http://wiki.ros.org/rospkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+ # Needed for tests
+ S="${WORKDIR}/${PN}"
+ EGIT_CHECKOUT_DIR="${S}"
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/ros-infrastructure/rospkg/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=(
+ "${FILESDIR}/norecurse.patch"
+)
+
+python_test() {
+ nosetests --with-coverage --cover-package=rospkg --with-xunit test || die
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ # Avoid recursing into /usr/share when looking for packages.
+ dodir /usr/share
+ touch "${ED}/usr/share/rospack_norecurse"
+}