summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-12 16:55:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-12 21:20:23 +0200
commite7c8f34bd20cf0421aba55f1f03fd5478679583b (patch)
tree6e2e3b5d2f73b75b51c9fde2f78b7bca994e1e5f /dev-python/rospkg/rospkg-1.1.1.ebuild
parentnet-misc/youtube-dl: Old. (diff)
downloadgentoo-e7c8f34bd20cf0421aba55f1f03fd5478679583b.tar.gz
gentoo-e7c8f34bd20cf0421aba55f1f03fd5478679583b.tar.bz2
gentoo-e7c8f34bd20cf0421aba55f1f03fd5478679583b.zip
dev-python/rospkg: Bump to 1.1.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/rospkg/rospkg-1.1.1.ebuild')
-rw-r--r--dev-python/rospkg/rospkg-1.1.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/rospkg/rospkg-1.1.1.ebuild b/dev-python/rospkg/rospkg-1.1.1.ebuild
new file mode 100644
index 000000000000..dff594067afb
--- /dev/null
+++ b/dev-python/rospkg/rospkg-1.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rospkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the ROS package system"
+HOMEPAGE="http://wiki.ros.org/rospkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+ # Needed for tests
+ S="${WORKDIR}/${PN}"
+ EGIT_CHECKOUT_DIR="${S}"
+else
+ SRC_URI="https://github.com/ros-infrastructure/rospkg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=( "${FILESDIR}/gentoo.patch" )
+
+python_test() {
+ nosetests --with-coverage --cover-package=rospkg --with-xunit test || die
+}