summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-08-27 18:14:12 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-08-28 19:01:30 +0200
commit3d67f6653c7fc8aefe0e4459308a91e5a47329af (patch)
tree51ae498bf640e6136c04cfc22793017819905e37 /dev-python/rospkg
parentdev-python/rospkg: Remove old (diff)
downloadgentoo-3d67f6653c7fc8aefe0e4459308a91e5a47329af.tar.gz
gentoo-3d67f6653c7fc8aefe0e4459308a91e5a47329af.tar.bz2
gentoo-3d67f6653c7fc8aefe0e4459308a91e5a47329af.zip
dev-python/rospkg: bump to 1.1.10
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python/rospkg')
-rw-r--r--dev-python/rospkg/Manifest1
-rw-r--r--dev-python/rospkg/rospkg-1.1.10.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/rospkg/Manifest b/dev-python/rospkg/Manifest
index c958ffd3d7aa..5508d2e11caf 100644
--- a/dev-python/rospkg/Manifest
+++ b/dev-python/rospkg/Manifest
@@ -1 +1,2 @@
+DIST rospkg-1.1.10.tar.gz 90434 BLAKE2B 1eb128d7e3f6d07e8309ecf5ea6c4340afcbb6f0618fd4628543c046003782750c5013c13ff2ed17018abc6efc6ce2042ccf2c6dccea8933be7045ddfe3f4522 SHA512 54b1b0ca4683b9388989501781239cf35873f2bf2028d176718f624999835b21e44f0cc5988624b37f7172d21f0c01aa336d35a884753c842098e558c37ac6c8
DIST rospkg-1.1.9.tar.gz 90412 BLAKE2B 4cca7d1ebfcba495aafd766f0d720a6bc6e5aade0bff098d4a1cbab3b55c7a720de7d1f97edf806a93cc21eeda4cac86e844b5e3b23f85cbcb7b328fd07da222 SHA512 d33005e29313ba06959189f8f563361fd9523c2368855f260347b4c509d8b4053f74db3e2cf5986031653d647ded097f272f65d617da93e13cf77a906cb56ca6
diff --git a/dev-python/rospkg/rospkg-1.1.10.ebuild b/dev-python/rospkg/rospkg-1.1.10.ebuild
new file mode 100644
index 000000000000..0e81f9b79bb0
--- /dev/null
+++ b/dev-python/rospkg/rospkg-1.1.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rospkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the ROS package system"
+HOMEPAGE="http://wiki.ros.org/rospkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+ # Needed for tests
+ S="${WORKDIR}/${PN}"
+ EGIT_CHECKOUT_DIR="${S}"
+else
+ SRC_URI="https://github.com/ros-infrastructure/rospkg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND} ${BDEPEND}
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=( "${FILESDIR}/gentoo.patch" )
+
+python_test() {
+ nosetests --with-coverage --cover-package=rospkg --with-xunit test || die
+}