summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-11 15:10:12 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-11 16:26:23 +0100
commitd427a102cf844db3a24c21c55b77d2fc4fa28e5b (patch)
tree43442018021eae17772ab4e7e0ecfa9625e0f248 /dev-python/rospkg
parentdev-python/rospkg: use yaml.safe_load (diff)
downloadgentoo-d427a102cf844db3a24c21c55b77d2fc4fa28e5b.tar.gz
gentoo-d427a102cf844db3a24c21c55b77d2fc4fa28e5b.tar.bz2
gentoo-d427a102cf844db3a24c21c55b77d2fc4fa28e5b.zip
dev-python/rospkg: add missing catkin_pkg dep.
Closes: https://bugs.gentoo.org/663946 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python/rospkg')
-rw-r--r--dev-python/rospkg/rospkg-1.2.0.ebuild3
-rw-r--r--dev-python/rospkg/rospkg-9999.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/rospkg/rospkg-1.2.0.ebuild b/dev-python/rospkg/rospkg-1.2.0.ebuild
index 49c3524f1d4a..d798eb107040 100644
--- a/dev-python/rospkg/rospkg-1.2.0.ebuild
+++ b/dev-python/rospkg/rospkg-1.2.0.ebuild
@@ -30,7 +30,8 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]"
BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
diff --git a/dev-python/rospkg/rospkg-9999.ebuild b/dev-python/rospkg/rospkg-9999.ebuild
index 49c3524f1d4a..d798eb107040 100644
--- a/dev-python/rospkg/rospkg-9999.ebuild
+++ b/dev-python/rospkg/rospkg-9999.ebuild
@@ -30,7 +30,8 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]"
BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (