summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-03 14:39:20 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-03 14:40:52 +0200
commit0dfefbed3b953289ad0e7b7795e18b1a08b14e59 (patch)
tree46c1df60aba1f8b030334609e2312cf979f54208 /dev-python/rply
parentdev-python/rply: Update coding style wrt tests (diff)
downloadgentoo-0dfefbed3b953289ad0e7b7795e18b1a08b14e59.tar.gz
gentoo-0dfefbed3b953289ad0e7b7795e18b1a08b14e59.tar.bz2
gentoo-0dfefbed3b953289ad0e7b7795e18b1a08b14e59.zip
dev-python/rply: Bump to 0.7.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rply')
-rw-r--r--dev-python/rply/Manifest1
-rw-r--r--dev-python/rply/rply-0.7.7.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/rply/Manifest b/dev-python/rply/Manifest
index 56b94d709409..4d6f2de390f8 100644
--- a/dev-python/rply/Manifest
+++ b/dev-python/rply/Manifest
@@ -1,3 +1,4 @@
DIST rply-0.7.4.tar.gz 27392 BLAKE2B 3604550646e083bf685a192dcf0dbc80c03cf4b97f6771ed37e228c84909c2518a58bde73ea584085351f1a2b5c865418ae671843087660d48f08e0e44e3ab2c SHA512 e3c3a828eb4b3cb20751ecb2d91efaabddbe3702d52b9adefe1748c07c843da1899e3944bcf0ab79f627ae428b8879cf99739ea7e0c6fd1acffc4ac4dee1b652
DIST rply-0.7.5.tar.gz 27462 BLAKE2B 0f438e6fd786e7436f135da50fe90208970a0950422bb0d8e26b06cc2def964c0ebd7c3e5e3e282a1d56dbb9e804ac267095dc4da16eb57899f455d66fed2d71 SHA512 ccecc451d9e2e0fdf9df7eaaeabface782d9159cc1caf1feae6e46210f6384aa1a78c15ea3c0e9dcc0bd0d2b28e3b1328c8d37e94a8968b07ef7938e5f5ce201
DIST rply-0.7.6.tar.gz 26216 BLAKE2B 5ec93739179df0d34762ea0ee004a00defa235a23af8b5cbf283e1e44c250469a704c9247463a8cdf9796c35da8aed0be025e73fe21aece3d376b1e66ffda1c3 SHA512 b0edcff1ca32c465b404a0b2f548f90d312bcb98d3f4aa4a61fb44986c8aa7ecb6f046e72112e2c1f5654173bcfcc96ab4e0625632e908ccf17b43cdb3d8d99d
+DIST rply-0.7.7.tar.gz 26366 BLAKE2B 09e6b93e9581745209b2d1fede6e0e4f08c2a34cc2495ea73aebb27b012353bbdb749ef127128cd5d9df201607f73625e248945038a927d788e324fb632341b4 SHA512 c01166b7df067a6a55d1b43caa7b5a349045e838899daf82e2ba70a2c2525fd68e95f11e5319a1fe36936e696352a37bdc13f132f739cd52759a9a9c91e317ba
diff --git a/dev-python/rply/rply-0.7.7.ebuild b/dev-python/rply/rply-0.7.7.ebuild
new file mode 100644
index 000000000000..cb3fca642b26
--- /dev/null
+++ b/dev-python/rply/rply-0.7.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python parser generator that also works with RPython"
+HOMEPAGE="https://github.com/alex/rply"
+SRC_URI="https://github.com/alex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}