summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-07 09:56:09 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-07 09:56:19 +0100
commit180d405a41b277428974932c8b439048fe05ac36 (patch)
tree3f1f79946a8670a7c0b1a4863278a3cdd2cefa61 /dev-python/rsa/rsa-3.2.3-r1.ebuild
parentdev-python/numpy: Version Bump (diff)
downloadgentoo-180d405a41b277428974932c8b439048fe05ac36.tar.gz
gentoo-180d405a41b277428974932c8b439048fe05ac36.tar.bz2
gentoo-180d405a41b277428974932c8b439048fe05ac36.zip
dev-python/rsa: Backport patch for CVS-2016-1494
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=570990 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/rsa/rsa-3.2.3-r1.ebuild')
-rw-r--r--dev-python/rsa/rsa-3.2.3-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/rsa/rsa-3.2.3-r1.ebuild b/dev-python/rsa/rsa-3.2.3-r1.ebuild
new file mode 100644
index 000000000000..42ff4a02a6dc
--- /dev/null
+++ b/dev-python/rsa/rsa-3.2.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python RSA implementation"
+HOMEPAGE="http://stuvel.eu/rsa https://pypi.python.org/pypi/rsa"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pyasn1-0.1.3[${PYTHON_USEDEP}]
+ dev-python/traceback2[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-0.6.10[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )
+ "
+
+PATCHES=(
+ "${FILESDIR}"/${P}-CVE-2016-1494.patch
+)
+
+python_test() {
+ nosetests --verbose || die
+}