summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-29 09:21:45 +0200
committerMichał Górny <mgorny@gentoo.org>2020-03-29 09:31:18 +0200
commitcc12d3350c5afdc9e232f1903c32d8f840bcccc3 (patch)
treed59ec16c1a690072ba56b4f7d3057abaeb8d6cee /dev-python/rst-linker/rst-linker-1.9-r1.ebuild
parentdev-python/rsa: Remove redundant versions (diff)
downloadgentoo-cc12d3350c5afdc9e232f1903c32d8f840bcccc3.tar.gz
gentoo-cc12d3350c5afdc9e232f1903c32d8f840bcccc3.tar.bz2
gentoo-cc12d3350c5afdc9e232f1903c32d8f840bcccc3.zip
dev-python/rst-linker: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rst-linker/rst-linker-1.9-r1.ebuild')
-rw-r--r--dev-python/rst-linker/rst-linker-1.9-r1.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/rst-linker/rst-linker-1.9-r1.ebuild b/dev-python/rst-linker/rst-linker-1.9-r1.ebuild
deleted file mode 100644
index 4a956f60c505..000000000000
--- a/dev-python/rst-linker/rst-linker-1.9-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Sphinx plugin to add links and timestamps to the changelog"
-HOMEPAGE="https://github.com/jaraco/rst.linker"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- ${RDEPEND}
- dev-python/path-py[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-python_test() {
- py.test -v --ignore=rst || die "tests failed with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install
-
- # namespace used only by this package in Gentoo at the moment
- python_moduleinto rst
- python_domodule rst/__init__.py
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
- distutils-r1_python_install_all
-
- find "${D}" -name '*.pth' -delete || die
-}