summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2018-01-27 02:03:19 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2018-02-07 12:12:19 +0000
commita64be65cfe9aec2718c18d16a8185d5a5f5114e2 (patch)
treee0f4ce1833ec575e9d051d8e235a1e634fc7030c /dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild
parentdev-libs/uriparser: 0.8.5 (diff)
downloadgentoo-a64be65cfe9aec2718c18d16a8185d5a5f5114e2.tar.gz
gentoo-a64be65cfe9aec2718c18d16a8185d5a5f5114e2.tar.bz2
gentoo-a64be65cfe9aec2718c18d16a8185d5a5f5114e2.zip
dev-python/ruamel-std-pathlib: add new package
Dependency of dev-python/ruamel-yaml, which is a new dependency of app-misc/khard and will be added to the tree in a following commit. Based on work by Foster McLane <fkmclane@gmail.com> Bug: https://bugs.gentoo.org/644994 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild')
-rw-r--r--dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild b/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild
new file mode 100644
index 000000000000..39663517d757
--- /dev/null
+++ b/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Ruamel enhancements to pathlib and pathlib2"
+HOMEPAGE="https://pypi.python.org/pypi/ruamel.std.pathlib https://bitbucket.org/ruamel/std.pathlib"
+MY_PN="${PN//-/.}"
+SRC_URI="https://bitbucket.org/${MY_PN/.//}/get/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python3_4)
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_install() {
+ distutils-r1_python_install --single-version-externally-managed
+ find "${ED}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ py.test -v _test/test_*.py || die
+}